WD TV Live Plus: won't launch Netflix player (Canada)

Hi, I have an older WD TV Live Plus HD Media Player and on the weekend (Oct 4 or 5) it suddenly stopped launching the Netflix player. When I choose that application, it either displays the WD logo after a few seconds (as if it’s rebooted) or the screen goes blank for a long time, then I get the menu again (sometimes I power cycle it after a several minutes, I don’t knkow whether it would eventually have come back to the main menu).

The box reports the firmware is current, the YouTube application works (so I know Internet is working), and it reports seeing my notebook on the LAN (no shared media at the moment, but it sees the computer).

Box was bought in Canada, is being used in Canada, and was working fine last week (and YouTube still works, as mentioned). I’m not fooling around with DNS settings to get a different Netflix or anything like that.

Is this a known problem?  Has anyone else seen it?


Have you tried resetting your WD TV Live Plus to factory defaults? I understand no settings were changed, however, it is recommended in order to clear any possible internal user interface or firmware conflict.


1 Like

I didn’t so I’ll try that now. Is it enough to use the menu choice (which I’ve seen) or is there a hardware factory reset?



Yes, a factory reset can be performed under settings.



Thanks, I did the factory reset under Settings and it seems to have fixed the problem. Of course I had to re-login to Netflix but that was assumed. It never occurred to me to do a reset because nothing had changed (AFAIK).

I’m also enjoying the YouTube feature where I can control YT from my Android phone and have it play videos on my TV (WD TLP attached). It’s a little flaky, sometimes plays the wrong things, it’s slow, and a couple of times my WD box has gone off and either frozen or rebooted. But I never expected Chromecast-like capabilities on my 24" CRT TV! :slight_smile:

Thanks again!


Hello, I am having the same problem, and I’ve tried resetting it several times through the menu, but it doesn’ solve the problem. Every time I click on the Netflix or Youtube app the wd tv live restarts itself. It also started around the same date (Oct. 4 - 5). I can’t watch Netflix. Restting the WD TV Live won’t solve the problem. Any help would be greatly appreciated.Thanks!!

as of the past week or so, netflix will open… I can choose a movie or tv show, but when the red buffering line starts… it only moves about 10% to the right… and the screen goes black… and nothing…

I reset my settings back to default… re-entered all my network connection info, re-signed up in netflix app… but still same results… is this a firmware issue?

Hi, I rolled back the firmware version and it solved the problem.

Maybe you should try the same.


What version did you rollback to that worked?