WD TV Live Plus-New firmware message

Now that I have it rolled back  how do I set it to stop bugging me saying there is new fireware

Basically, you don’t unless you do some things that I recommend you not do.  We just have to “live with it” and be careful not to tell the WD to update firmware.  Tell anyone else using your WD not to do this either!! YOU are in charge of this task, (and tell 'em why).

search the firmware thread…there are a couple solutions listed there.


Block it in your Modem / Router settings.

eg. i have a Billion Modem/Router  (you only need to enter the 1st address … the other one blocks sniffer code in later devices)


I finally decided to do this today, for my Live Plus units  and I had to go into the Firewall/URL Filter tabs of my ASUS router.  The router would not accept the string:  http://support.wdc.com/  (didn’t like the non-alpha characters) so I shortened the string to “support.wdc.com” and the router liked it.  Of course, the upgrade firmware is not even on the settings menu and I can’t even call it up anymore when I go into Settings.

Also, I can not go to http://support.wdc.com/ via my PC anymore, so I suppose if I wanted to do this I would need to remove the URL Filter temporarily in the router, and reapply it again when done.