WD tv live plus- netflix - retrieving -> no screen no audio -> stop and back to thumbnails


#1

WD tv live plus- netflix - retrieving -> no screen no audio -> stop and back to thumbnails

Hello, I have two problems now, A and B.

A. Netflix, when playing movie, does not show video nor audio

I installed the WD tv live plus and everything works fine except Netflix. (I activated)

Problem is as below,

  1. go to my queu and click play, title of the movie and “retrieving” is shown (I rarely see the RED bar filling)

  2. soon the movie title disappears and “retrieving” disappears and now all I see is a BLACK screen. No video/audio.

  3. after waiting several minutes I press “stop” from my remote and I go back to the movie thumbnail and description screen.

I have activated, and also inside setting audio/video I played with various options but nothing works.

B. Since nothing worked I DEACTIVATED my WD tv live plus through website. I was trying to REACTIVATE thinking that it might solve things. But the problem that I have now is as below.

  1. On Netflix website my device is not activated.

  2. On my TV I can still view movies queus and categories.

  3. I cannot get the new activation code.

Please help, I bought this tool only to watch Netflix.

Now everything works BUT netflix and I feel so sad.

Thank you very much in advance.


#2

Are you using HDMI connection to your TV?   If so, I’ll bet you have an HDCP issue between your TV and your WD.

Try connecting it with COMPONENT VIDEO cables (or composite) and see if you get a picture.


#3

First, thank you for your help.

I will try with the component cabel this evening, and I hope that it works.

I saw similar issue, rare, which you can find below but still it did not state any solutions to the HDCP problem.

http://community.wdc.com/t5/General-Discussions/Netflix-Instant-Q-loads-but-blank-screen-for-video/m-p/155972

What options do I have to solve this issue, which means, I want to connect through HDMI only.

If my WD tv live plus and TV does not work together through HDMI, I will have to return the unit.

So any solutions to connect with HDMI?

Thank you very much in advance.


#4

FYI,

I have also tried disabling and enabling the “auto-negotiation of video frame-rate” which is mentioned in other post.

Also tried multiple various choices but still things were the same, black screen.


#5

Unfortunately, there’s not a lot that can be done.

HDCP is a rather recent beast.   It’s been around for a long time, but it’s changed a lot in specific protocols.

If it’s not working, it’s unlikely it ever will. 

Double check your TV’s firmware and see if there’s an update for it.

http://wdc.custhelp.com/app/answers/detail/a_id/5854/


#6

Tony.

I just went to my plasma website in search for a firmware.

http://www2.panasonic.com/consumer-electronics/support/Televisions/VIERA-Plasma-HDTVs/Warranty-CCP/model.TH-42PX50U.W#ts

TH-42PX50U, it looks like there is no firmware for my TV.

Also, can I buy a component to hdmi UNIT to connect like below order?

WD tv live plus - component - UNIT - hdmi - Plasma TV

Do you think it’ll work?


#7

That would probably work, but keep in mind that component Netflix is limited to 480p…