WD TV Live Plus freezes upon startup

Hello all - I apologize if this has been addressed, but I haven’t seen this problem specifically posted.

My WD TV Live Plus ( http://www.wdc.com/en/products/products.aspx?id=320)) has started freezing upon startup. It has worked fine for about 9 months. I’m not sure when I last updated the firmware - it has been some time. 

Basically, it boots up and reaches the main menu screen. After about 5 seconds the remote stops responding and the screen freezes. There is no screensaver, so I assume it is not the remote itself that is unresponsive. I’ve disconnected the harddrives in case it was having difficulty reading them. I haven’t touched the Cat-5 cable that connects to the router. I have tried twice the factory reset button. Once the screen freezes, the factory reset button is disabled–I’ve managed to use the reset button during the initial 5 seconds of booting up, but after that it is useless.

Any help is appreciated! All I wanted to do is watch Top Gear on Netflix, while nursing a hangover. Is that so much to ask? 


The unit has failed dude

not much that can be done