WD TV Live Plus - Can't Play ANY File

I had a USB PenDrive hooked to my WD TV Live PLus with only 1 video playing on a exhibition.

It worked for 6 days without any problems.

On the 7th day the WD TV turned on but displayed the message: Unable to Play the Selected File

I’ve read older posts here that say I should create a root folder for my Movie, but it didn’t work.

I’ve formatted the pendrive, tried with other pen drives, other files, images, music, tried with a HD that was working before.

No way to make it work again.

I reseted to the factory defaults, reseted phisically and upgraded the firmware.


Any ideas of what may be the problem, and the solution?


Same here with my USB-Disk. Cannot play any file, even those that did work before. Factory reset didn’t work as well as unplugging it for hours.

i was actually having the same problem (i flashed my media player to have movie sheets thumbmails etc etc) but what i did was just update my firmware to 1.03.49 and every thing works fine now i had MKV Header Compression enabled which didnt work on base firmware so i had to update