WD TV Live not seeing USB shared drives on Win10 PC

I had external USB drives shared under Win8.1, accessible from a WD TV Live box through windows shares.

Since upgrading to Win10, I can’t see the folders shared in those USB drives anymore from the WD TV Live. I can see folders shared from internal drives, though. I’ve tried removing the shares and recreating them, to no avail.

Please note the USB shared folder can be seen from a Mac in the same network without issues.

Anyone knows if I am missing something, or did Win10 break something with USB drive sharing that only affects the WD TV Live?

You are not alone. Read here

Btw try these steps:
In File Explorer, choose the folder you want to share and right-click it, choose “share with specific people”. The word “everyone” should be in the bottom window. If not, use drop-down box and select “everyone”, then press “add”.
In settings, Network & Internet, Change Advanced Network Options, All Networks:
Turn off Password
In Media Streaming / Choose Media Streaming Options
WDTVLive Allowed


Thanks! That was already working, the problem was only with external USB drives, internal shares were working ok (which is what was driving me crazy).

Anyway, I kept digging around online, tried a few things and eventually found a solution: A registry key needs to be created, called IRPStackValue. It existed on previous versions of windows, apparently, but not on Windows 10. I gave it (after several tries) a value of 32 (Hex 20).

After creating the key, WD TV Live shows both internal and external drives. Also, I checked the event log for my system, and sure enough, it said the IRPStackValue was too low, which begs the question why does the key not exist, but that’s another point :slight_smile:

In case anyone stumbles unto this, this is the way to create the key:

  1. Run regedit.
  2. Navigate to the following key:
  3. In the right pane, double-click the IRPStackSize value (if it exists already, if not, see below). In the Value Data box, type a Hex value of 20 (32 decimal) and then click OK.
  4. Close the Registry Editor and restart the computer.
    If the problem continues after you complete the preceding procedure, try to increase the value of IRPStackSize even more. The maximum value for Windows 2000 was 50 (0x32 hex), so you should stay below that. In my case, I started at 11 (I saw somewhere that was the default value) and ended up at 20.

How the create the IRPStackSize value:

  1. In the Parameters folder of the registry, right-click the right pane.
  2. Point to New, and then click DWord Value (32 bits).
  3. Type IRPStackSize exactly as it is displayed because the value name is case-sensitive.

Hope this helps other people.