WD TV Live not being detected as a Media Device through a wireless network


#1

Hi

I try to use the “play to” feature. I’ve got Windows 7 64bit and I’m using the latest pre release firmware on the WDTV Live.

Now if i plug my pc into the router through a network cable the WDTV is detected as a media device and “Play to” works fine.

However when i connect the PC wirelessly,  i see the WDTV on the network, i can access the share drives etc but the wdtv isnt detected as a media device by windows and therefore the “play to” functionality doesnt work.

Ive tried this with my firewall disabled and still have no joy.

I’m thinking maybe some ports are closed through the wireless settings on the router but i have no idea which ones need to be open.

Any ideas?


#2

It may be a PROFILE issue on your PC.

Win 7 will usually set up a different profile for Wireless compared to Wired, and different functions and features will be enabled or disabled as a result.

Go to the “Advanced Sharing Settings” when you’re on Wireless, and make sure that profile is set up correctly.


#3

Thanks for the tip. Ive checked the profile and the advanced sharing options and they are the same for the wired and wireless networks.

I’m at a loss what it could be. ive tried turning my firewall off with no luck.

Is there anything i have to do to the router to allowing the wdtv live to be seen as a media devie?


#4

Not Usually…


#5

I solved the problem.

As suspected the issue was with my ISP provided modem/router. A D-link G3810.

There apparently is a problem with how it bridges Wired and Wirless connections. I disabled the wireless and bought a new router and installed it as a wireless access point  and everything is talking to each other fine