WD TV Live Hub/WD My Book 3 TB HD *Please Help*

Last week I wanted to transfer some family videos and tv shows from my WD My Book 3 TB external HD to my mother’s WD TV Live Hub. I plugged it in and waited about 5 minutes for the hub to recognize the HD. After unplugging/plugging the HD from the hub and restarting the hub it woudn’t detect it. So I plugged in a LAN cable to see if the hub needed to be updated and I found out that it did. Now here’s the part I THINK what I did wrong. I left the HD plugged in as the hub was updating. It failed to update the first time so I figured that the HD was what was causing the hub to not update. I unplugged the HD and the 2nd attempt to update the hub worked. After the hub restarted I plugged the HD back in and the hub detected it. Before I started transferring files I wanted to check to make sure the files worked. There were a lot of videos that wouldn’t play and the hub was saying that the files were unsupported. 75% of the videos that I played actually worked. It was odd becuase the videos that wouldn’t play had actually played before. I took the HD back to my laptop to see what was going on. When I plugged the HD in to my laptop I noticed that some of my files were showing 0kb. I also noticed that my HD was showing that I only had 10GB out of 800GB. I unplugged the HD and plugged it back in. From there my laptop keeps and asking if I want to format it. After researching online to find a fix for my issue I found out that either the filesystem is damaged or the partition is damaged. Under disk management it shows the HD as RAW. Currently I’m using testdisk and I’m able to copy the files over to another HD. This is temporary at the moment but I would LOVE to have my HD working again without having to reformat it.

Hi and welcome to the WD community.

As you say, it is possible that the files got corrupted. Before disconnecting the USB cable from the WDTV, be sure to always press the eject button located on the bottom right side of the remote controller. See page 21 of the manual for more information. 



Raw is a corruption issue. This might also work http://www.easeus-datarecovery.com/data-recovery-solution/raw-drive-data-recovery.htm  Also I have seen running the command prompt to convert FAT32 to NTFS posted as a fix. Here is a link with the prompt http://support.microsoft.com/kb/214579 it’s about halfway down. I would only thry that as a last resort.