WD TV Live Hub Problem

I just got the WD TV Live Hub. I hooked it up to my TV and it seemed fine. When I connected it to my home network, it suggested a firmware update. I allowed the update but when the unit rebooted, it never turned back on. I turned it on manually and since then I cannot see anything on the TV after the initial splash screen. My TV says it is an unsupported format. I have tried using the reset on the bottom of the unit but with the same results. I have it connected to my TV via component cables and my TV is 720p. Any suggestions?

Welcome to the forums.

Try unplugging it for at least 10 minutes and then see if it works. 

Try using a composite lead.

I resorted to the ten second reset which, according to the user manual, changes it from NTSC to PAL or vice versa. I had to do it twice but it worked. Even though I have the unit connected to my TV via component cables, the unit says the output format is “Composite (NTSC).” If I try to change this to component 720p to match my TV, I get a rerun of my initial problem and have to go through the ten second reboot, twice. Also, this is MINOR but the interface shows time and temperature in the upper right corner. I can change the time zone to get the clock set but how do you set a location for the temperature? I can guarantee you it is not 89 degrees here in Minnesota in November.

Log into your weather app. and change your location there.

Sorry, I don’t know what you mean by my weather app.

Go into services, select AccuWeather, and set your location. Then your temperature should be correct.

Ah, thanks. I’ll try it.