WD TV Live Hub Media Library Complie Issue


#21

I just wanted to chime in and say that I too am having this problem (after a network file sharing sync). I’m going to try some some things. Let you know. This issue is a REAL drag!


#22

I too am having this problem.  I just bought this last Saturday and haven’t been able to really use it at all.  I may take it back tomorrow.  Somebody at WD needs to fix this ASAP.


#23

Fixed! Here’s what I did that seemed to fix the issue.

I’m using Vista and was just storing my media in the standard “Pictures/Music/Videos” folder. To access the data, I just logged into my computer from the Hub with my main computer log in credentials, which not only accessed my mediea folders, but also every other folder that is shared on my computer (Documents, App Data, etc.). It was way to much ‘■■■■’ and the Hub probably choked on one or more of those files.

So what I did was create a new “WDTV” user (or whatever you choose) on my computer, and from Windows Explorer, I added the “WDTV” user to JUST the Pictures/Music/Videos folders via the “Share…” function. Then, back on the Hub, I reformated the drive and changed the network share log-in to the new “WDTV” user.

I let it resync over night and the next day I recompiled the media library. I don’t recall how long it took to compile the media library, but it was only several minutes. Previously, it was compiling the media for a couple days before I stopped it. In total, I have about 8,000 media files. Everything now appears as it should and it works great!

I don’t know if that’ll work for others, but it worked for me!

I don’t know if there are multiple wrong ways to do this, but there are probably a couple of right ways that work. WD needs to put at least a couple of those in the manual, FAQ or somewhere. The documentation for this great device is very poor.


#24

Here is something you might wanna try. Worked for me.

I was having the compiling issue when i was trying to get the unit to recognize playlist files, even when I wasn’t messing with the playlist files it would go thru the compiling for ever for no reason seems like. Finally got tired of trying to get the playlist files to work and just deleted them from the live hub 1tb hdd all together, created directories which contained just what I wanted to hear, Jazz, RnB, SoftRock and so on, everything in the playlist files. Not sure if it was a paticullar music file or the playlist files it didn’t like.

Still have all my video file in place with no change. No more Compiling Issues so far.

Marc


#25

I am not having the same problem but something to the same effect. I am able to get the hub to complie my media from my shared network drive on my PC the problem is when I add new media it doesn’t see it unless I turn off the media library and turn it back on and let it complie again. Any idea why it doesn’t just see right away?


#26

This is an issue that I have been having ever since I purchased this unit.  I like the unit, but it is driving me nuts!

I would love to use playlists to play the media but I cannot get them to work for me.  The “compiling Media” alert never goes away.

I am going to try another reset and follow what has been suggested here, but like I said, it is driving me nuts and I don’t  believe that I don’t have the understanding of computers to be able to set this up.  This should not be difficult.


#27

So, if I do a reset from the remote (reset to factory default) the unit will compile and list my items in about 10 minutes.  When I try to run a playlist (Playlist in directory where files are) it just comes back to me and gives me an error “The last content source has been removed. Please select a new content source” ???  WTH??  This really is frustrating.  If I could just figure out what the content source it is talking about it might make it a little more clear.

Anyone got any ideas or suggestions??  About to throw this thing away and chalk it up to a bad experience.


#28

eastcoast:    Can you post a portion of your playlist?

Also, are ALL of the files on the hub’s internal drive, or some other location?


#29

Hello, I too I am experiencing the Media Compiling message that will not finish.  Bought the unit yesterday.  It automatically updated firmware off the net (no problem), connected external drive via USB.  Played files off the drive no problem, however then tried sysncing the drive (and compiling media) and hasn’t stopped.  There is only say 50 small AVi files on the external drive.  Powered unit off and still same problem.  This is very frustrating as there is no way to determine what is causing the issue?

Is there a way to get the resolution status from WD?  Otherwise the unit is going back.

Thanks.


#30

I too have the same compiling problem, light has been flashing and hub compiling for 1 week so far.

Tried most things I’ve read on here.


#31

My machine have been compiling files for 10 days straight now and the logo on the front have been blinking during the whole process. 

I doubt this is a normal behavior and I have nothing shared on the network or plugged into it, I just copied 60 movies and around 500-600 music albums to the hard drive.

I have good structure on my files already, so I also wonder why the software are adding all the artwork from my music albums into the photo gallery? It is not like I would love to browse around among the artwork for my music albums.

Anyone know how to turn these annoying feature off?


#32

Just turn off the media library in the setup menu.


#33

I too am now having this issue.

Everything was fine till I did the following:

In the “Videos” section, on the internal drive I have created folders.

Movies, Temp, Kids, TV, Work-out

I grabbed icons off google images for each folder. put them in the their respective folders and named them folder.jpg

These worked perfect since I put them there. Then Tinwarble pointed me HERE  for some awesome icons.

I have grabbed the ones I want for each of the above folders and replaced the ones currently in there.

I look in the folder and open the image on my PC and the new image is there, named folder.jpg.

Yet on the TV it is still showing the old image.

I have tried rebooting the hub, turning off and on media library, I have cleared media library and recompiled. I have deleted the corrosponding 5 thumbs in the hidden WDTV folder. Nothing seems to work. Its still showing the old images for all of them.

I then decided to:

  1. turned off media library

  2. clear media library

  3. from PC deleted everything in the “U:.wd_tv\thumb” directory

  4. rebooted hub

  5. turned on media library and now its been compiling for over 2 hours

There is only 91G of data being compiled. All videos… no music or photos. And all on internal drive.


#34

What worked for me is:

  1. turn off media library.

  2. Clear Media Library

  3. pull the network cable and power cable from the back [not just the power button]

  4. wait 5 seconds and put back in power button cable only

  5. turn on media library and wait for internal to finish compiling. Shouldnt take more than 30 minutes [mine took 5 mins as I only have 91G so far]

  6. When done compiling, plug in network cable to compile external devices


#35

I’ve only had the device a couple days, but I’m currently also noticing this issue.  The compiling ran all night last night and was still running this morning.  I have nothing on the internal drive and 1 2TB NTFS usb seagate connected with maybe 300 GB of media files.  I also have other non media files on my usb (document files, word, pdf, text, some binaries, etc) and i’m wondering if maybe that’s confusing the hub.  In any case, I’m going to try to reorganize and clean up the files on my usb.  If that doesn’t work I will try removing all files from the usb and then testing the compiling with an increasing number of files.


#36

I am also having this issue. I bought my WDTLIVE 7 days ago and the darn thing is stuck on compiling.


#37

EDIT: Sorry, did not notice that there were posts after this that gives an answer :smileyvery-happy:

ecatapano wrote:

I am not having the same problem but something to the same effect. I am able to get the hub to complie my media from my shared network drive on my PC the problem is when I add new media it doesn’t see it unless I turn off the media library and turn it back on and let it complie again. Any idea why it doesn’t just see right away?

The hub will compile media added to its local hd and attached USB hd’s, but in order to reflect updates on a network share you have to re-compile the media library!