WD TV Live Hub Media Library Complie Issue


#1

I have spent 3 days trying to resolve an issue with the compiling of the media library. All that happens is that it continually says Compiling Media Library. I have left it for hours and it never stops. It seems to be something to do with the amount of data I have on the internal hard drive. I have tried clearing the media library and reformatting the drive but nothing helps.

When I first reformatted the drive I placed 3 avi files on the drive with a playlist. With just these few files the media library built quite quickly and worked as expected.

I have left the media library compiling for 12 hours and the only way it stops is by restarting the hub, However when you do this and try and access the files it tell me that the “content source has been disconnected”.

I am currently running at the latest firmware v  2.02.16


#2

Just how many files are we talking about?


#3

Currently I have about 450 avi files.


#4

It might be that some of them have file names (or folders, if applicable) that have a character in them the Hub is choking on when compiling the library.   It should only take about one or two minutes to compile 450 files.


#5

I have had these files on USB connected to a WD TV Live with out any issues. Do you know if there is any way of viewing the database it creates?


#6

Unfortunately, it’s on a hidden partition that isn’t user accessible.

Here’s another (though tedious) idea…   Copy the files in batches.

Start with, say the first 200 files.

Try to re-compile the library.

If it works, copy the next 100, etc.

If it DOESN’T work with the first 200, then clear out the latter 100 of that batch and try again.

In other words, try to home in on the particular file(s) that’s causing the issue.

I’ve had as many as 16,000 files on my hub at one time (mostly photos, 3000 MP3s, and about 200 MKVs) and it only took about 10 minutes to index everything.  So, you’re definitely not running up against a “Quantity” limitation.  I think it’s just getting gagged by one or a few files.

Once you find out which file is the issue, we can look at that to see what the issue is.


#7

Thanks, I had thought of that but was hoping to avoid it. :smiley:


#8

I have received confirmation from Western Digital support that this is an issue they have been able to replicate and are in the process of resolving.


#9

Ok, exactly what is the issue?


#10

I was told by WD to upgrade my firmware to the lates which I did, Below was my last communication to the support team about a week ago and today they confirmed that they have the same issue.

have updated the Hub to the latest version as per your instructions but am still experiencing the same issue. What I can tell you is that after the update the media library did finish comping but when trying to view the videos after about a minute of waiting a message came up saying the content source had been removed. It is all on the internal hard drive. I don’t know why it was saying this.

After that message further media library compiling continued without stopping.

I have also tried pressing the reset button on the underside of the unit. This allowed the hub to compile the media in a few seconds, but again would not locate the media showing the same “content source has been removed” message.

I’m sure if you were to try this you would get the same results.


#11

I am having the same issue. What is the lastest on getting this resolve? Does anyone else any suggestions?


#12

I am still awaiting resolution by Western Digital. They are not being very quick about providing the solution. I would suggest that you also log the problem with them. The more people that do the quicker they might act.

The last communication I received this week was to try disabling the sync function. I have informed them that I had already done this and it hadn’t helped. I also pointed out that that is not an expectable solutions as the sync option is a useful feature.


#13

I am having the same issue.

I have disabled all sync functions, no USB devices are plugged into the device, and i have the latest firmware. Mine has been compiling for a couple of weeks at least. I moved all of my media to this device and off of my dying NAS so if i loose anything now it will be be gone for good.

I am going to open an issue with them as well to help make sure Wd knows how widespread the issue is. If i get any useful feedback i will relay it here.


#14

How widespread?   2 people here in the forum?    


#15

Do you think the 2 people in this forum are the only people on earth that are having this problem? OR that people here are the only ones to contact WD about this? I think that if only 2 people were experiencing this problem WD would not take the time to even look into the issue, which they appearently have to some degree.   [deleted]

I could be entirely wrong but because I do a similar sort of job i know that it helps to have as many details of related cases on record as possible to try to recreate / resolve the problem.

[deleted - off topic - not relevant and not respectful]


#16

BryanC wrote:

 

[not relevant]
 

what were your other 4,000 posts about?

 

If you click on his user name then you will find out.


#17

If it doesnt make this light on the front of the box stop blinking then i dont really care what they are about. Its driving me nuts. It has to stop compiling at some point. and up until now it seems that the posts on this subject were all relevent and meaningful.


#18

No, I’m just saying only a couple of people reported it on the forum, yet you are saying it’s a widespread issue.   How do you know that it’s widespread when there’s very little conversation about it?  

I’m just curious what your source of information on this issue is, that’s all… 

paul is working with WD on the issue, and until he or they give a resolution, there’s nothing further about this issue than has already been reported.


#19

And now for something usefull…

I have now managed to find the issue I was experiancing. I was trying to use playlists with a mixture of specific avi files and folders. Folders were used where I have box sets of films. The old WD TV Live box could handle this, but when you have the media library enabled on the HUB it couldn’t. it would put the library in some sort of loop if you selected one of these play lists.

To get out of this constant flashing and compiling you have to reset the HUB. When I modified the play lists to only have folders listed or files it works fine with the media library enabled.

If you are not using playlists in the same way I was I would sugest you try resetting the device, as it should clear the compiling issue.

Hope this helps


#20

Ok, let me jump in on this.

I do have the same endless compiling library issue. So that’s make at least 3 of us.

I don’t use playlists, so this is not the cause of my problem.

I have thousands of musics, photos and movies in hundreds of directories along the internal and 2x2Tb external hdd…

So this weekend I will do the folowing: I will disable the media library, reset the unit, unplug the external drives, (re)enable the media library, and wait for it to finish compiling the library for the internal drive before plugging the others, and then plug on one external hdd at a time… and pray for it to work. I will share the results here.

But how difficult would it be for WD to include a debug option or a status bar for the compiling library on a next firmware release?

What will I loose when I press the reset button on the back? My network settings?

Renato