WD TV Live Hub lost auto detect audio via HDMI pass through after firmware update 3.00.28

After the latest firmware update 3.00.28 to my WD TV Live Hub It seems to have lost audio on certain formats that worked fine before the update.

Now I have to go manually to Setup – Audio - Enable Digital pass through via HDMI only and select “Manual” option.

Before it was setup to “Auto” and I never had to change this option, now depending on what audi format is used I have to mess with this parameter.

This started immediately after the firmware update.

I am surprised no one has mentioned this so far.

does anyone have a fix for this issue ?

Thank you.

I just saw this article from the knowledge base of WD


I hope this is not the answer as this was not an issue before the FW update, I have over 300 movies and re-encoding formats is not the answer at this point.

WD Support please look into the issue futher and please come up with a fix.

Thank you.

Okay since no one has said anything or got this issue.

I would like to inform the users here that I downgraded the firmware from 3.00.28 to 2.8.xx, the version right before the latest.

The audio problems disappeared and now it works as before with Dolby or AAC.

I notified WD Support and they mentioned that they are working the issue on their next firmware release.


I’m using FW 3.0 and yesterday I lost ALL the audio. It didn’t matter what I played through the Hub there was no audio. Once I determined it wasn’t my surround sound system letting me down I had to do a full reset of the hub from the settings menu to get the audio back. I still don’t know why this happened…but I’m listening and making mental notes about what I do on the Hub so if it happens again maybe I can pinpoint what caused it.

I am having similiar issues as you are.  I just ended up going back to stereo only on the audio output.  No dolby digital even though the unit shows it when bringing up the informaiton.

As was posted earlier, Downgrade the firmware to 2.8xx then upgrade to 3.00.28 and the problem will be fixed, I had the same problem and I fixed it the day of the firmware update by doing this so I know it works. So far it looks like this is the only waty to fix it so far but was assured by WD it will be fixed on next firmware update.

Very easy fix so that is why you haven’t seen too many complaints, I just thought it was a glitch and that is why I rolled it back then reinstalled and many others probably did the same, I know I couldn’t be without my DTS for an hour let alone weeks as you have said.

I haven’t done it yet but I will give it a try. Basically, you said to downgrade then upgrade again and the sound comes back.

Interesting because, WD support didn’t suggest this at all when I reported the issue.

I will try it and post back.


I downgraded to FW 2.8 and upgarded again to FW 3.0 and still the same issue.

I said in my previous post that I am going to try this method as someone has suggested but that didn’t help.

My Dolby recorded movies do not play with any sound and this is only with FW 3.0

The only way I can get sound from them is by switching to stereo which I don’t want to do.

With FW 2.8.X all my movies in Dolby still play without any problems.

So I am now in FW 2.8  :frowning: