WD TV Live Hub drops connection when trying to copy over video files (wireless network)

Hello all,

Just got my new WD TV Live Hub and am very excited to get it up and running…i had been using a hacked AppleTV with XBMC on it to stream movies, but it recently had been buffering too much on movies so I wanted to buy a solution with built in media storage.

I have dual band 802.11n Netgear wireless routers and access points connecting my computer and the Hub (cable internet goes directly into Wireless Router #1, computer is hardwired into that router…and then Hub is connected to Wireless Access Point #2…hopefully that helps paint the picture of my setup)

Anyway, the Hub was totally plug-n-play…it found the internet no problem and I downloaded two firmware updates back-to-back.  It also was able to find my shared folders on my computer, and I was able to see the WDTVLIVEHUB “server” from my computer (running Win7 64bit btw).

I tried to stream a 720p movie but it stuttered…not too surprised since it was doing that on my AppleTV/XBMC setup (side note, if there’s ways to tweak my wireless so it can stream it without buffering/stuttering, let me know!!!)

I copied a movie over to a USB stick and played it…was flawless of course.

But *then* I tried to copy that movie (about 3GB file) from my computer over to the WDTVLIVEHUB folder…it started to copy it over and said it would take about an hour…but after a very short time I would get an error that the WDTVLIVEHUB was no longer accessible.  Of course, if I went to go look for the hub, it was there and ready to take the file.

I’ve tried normal dragging-and-dropping the file as well as using a program called Richcopy.  Nothing seems to work.

Is this an issue with my wireless setup, or the hub, or both?  Any assistance will be greatly appreciated!

You can try connecting the Hub to the same router the computer is attached. You did not specify if you have the Hub connected wirelessly, I suggest you to have it wired to compare results.

Mine does the same thing. Ive had this for over a year and sometimes it works sometimes it doesnt. My livehub is wired to my wireless modem. My computer is connected wirelessly to the modem. It starts out downloading at several mb but within minutes its at kb and looses connection.

Not certain if this will help, but I had similar problem if my WD Live Hub was on … copy stopped the moment the screensaver kicked in.

If the WD Live Hub is in sleep mode or if screensaver is disabled, so problem.

Worth a try.


I’m having the same issue with my wd tv live, will check the screensaver option! That will be annoying if I have to turn it off every time I copy.