WD TV Live Hub - Can't detect Network?

Just hooked this up tonight and a strange problem. I run setup and it see’s network fine. Tells me an update is available and all goes fine. I setup my netflix with no problems. I move movies through the network to the drive fine. Everything works great… untill I try to link to my facebook. I enter my login and password, click connect, spins for a bit then tells me it can’t detect my network. Go back and try netflix and no problems. Do a network test and it passes. Go back to facebook and can’t detect my network. Any ideas?

do you have LIVE ESSENTIALS installed on your PC?  that blocks mine from connecting, i had to remove it completely from my PC.

not sure about the facebook and other programs, but i could still connect to youtube and such, just not my NETWORKS SHARES, but once removed it from the PC, it worked fine.

Live Essentials doesn’t seem to be a factor here, as he’s only having a problem with Facebook.

I am, too.  Exact same thing.

I think they’ve got a bit of a bug, and it’s a known issue.   :) 

Update: Today it connects with no issue and works great. I made no changes at all. No I don’t have Live Essentials installed. While it was giving me issues I could log in to facebook from my computer on the same network.  Lets hope it sticks.

I had to put the WD’s IP Address into my firewall program (ZoneAlarm Extreme) before I could get the WD to find my network drives and devices.   This could be why many are experiencing network problems.  (I’m using Win 7)

Same problem here, everything else works like a champ over the network/online. Facebook, however, gives me the error “no network detected”. I can exit out and everything else operates as it should. Is this something WD is working on.

I also noticed that after I enter the password and it returns to the check box to continue in the field where my PW is located they’re many more astricks representing characters then are actually in my PW.

Any help on the matter would be appreciated.

All I can tell you is, the very next day I tried it again and it magically fixed itself over night. My box has been working perfectly ever since. WD email support was no help at all.

I’ve just had this same problem.  My live hub is only two weeks old and this is the second problem I’ve had with it.  First iff was the MKV problem - so I switched sound settings to stereo - which eventually worked.  To fix the lost IP address, I did a factory reset on the live hub, then disconnected all the cables into it (power, HDMI and ethernet) and left it for 10 minutes.  I then did a factory re-set on my broadband router (sticking a pen-nib in re-set hole).  Switch it all back on then everything works.

WD support (by phone) was no good with the MKV sound problem (they didn’t even say it was a “known” problem so I told them to look on their own WD community forum to see the amount of postings about it. They just suggested I send the device back to the supplier to exchange it under warranty.

Hopefully they’ll put a fix in the firmware soon.

Hope the above is of help to someone.

Same problem here – anyone come up with a solution other than just waiting for it to iron itself out?  Everything else works fine – it’s just facebook that’s a problem.

Same problem for me. All services (youtube, flikr, etc.) and shares work except Facebook and device registration (can’t detect network).

Same problem with Faceboko App, can someone from Western Digital Support please contact me or us with a solution.  Thanks.


Thought I would add my voice to the few that are also have the facebook network connectivity issue.  Please WD,take a look at your forums and rectify this problem.  Or at least comment on it out of professional courtesy.  Thanks


The WD Community was created for Users, such as yourself, to help one another, and to share your experiences and ideas with one another. As Moderators, we are here simply to facilitate and oversee the community. If you have a question relating the what’s going on in the community, we will be happy to respond. However, if you are looking for technical support from WD, you will need to contact them directly.

To Contact WD for Technical Support

Thank you for replying, I will follow up with a support email, however, do you know if this is already being investigated or have the previous forum memeber aslo not submitted any support requests?