WD TV live HUB and HP495 media smart server share folders problem


I have the WD TV live HUB with latest firmware connected via cable to a linksys WRT610N router acting like an AP, connected via cable to a ASUS RT-N56U router acting like a router (big house). This router connects to a HP media smart server HP495 via cable, and serve 2 notebooks via wifi. The network is Giga, all cables cat6.

Ok, my problem. I cannot see my shares in the NAS (HP495) from the live HUB. I can see shares from all the notebooks, no problem. On the notebooks I use WIN 7 64 bits ultimate. The HP495  runs Windows Home Server witch is a kind of Windows Server 2003. I can se the HUB from any computer or the NAS itself, no problems, but not the other way around. Using DNLA I can see from the HUB all media servers, including the ones on the NAS (Windows and PS3 media server for example), but not the shares. The HUB is in the WORKGROUP group, and I have cleaned the password it stores.

So far I have tried:

  • Put ‘everyone’ in the shares and in security giving permission to read and write. The hub just says that the user/password is wrong (it uses anonymous as default).

  • Created a user with access to the shares. Again user/password is wrong ( From my computers I can access the NAS using this user)

  • Used the administrator account. Again user/password is wrong

  • Disabled firewall on the routers and NAS (But I think is not the problem as I can see the media servers, including NAS, and the shares in the notebooks)

So, anything I try just gives me wrong username/password. 4 days so far and I cannot find anything on the net.

Any suggestions?

Thank you


See if this tutorial for troubleshooting helps:


Hey  TonyPh12345

Excellent topic. I had never heard about master browser before. So thank you I will look it up on the net.

Well, my problem is a username\password problem, so I think have a permissions problem. I can see the server, but not the shares because of the wrong username\password. I think this will be very hard. I have tried “everyone”, a known user name and even the administrator user. Both share and permissions. 

And the sad news for me is if the wd hub cannot see my shares where I store everything about me and my family this device is as good as nothing.

I will try something else. I will have you guys know if I discover something.

Thank you

PS: No more whs (before 2011) users here? 

Okay here it goes,

I had to install a sniffer network tool (i think that is the name) in my whs machine, the HP495. Wireshark is the name and is excellent! Google it. Then I filtered the wd tv live hub IP number (in my case I fixed it in using the WD GUI).

Whenever I try with  the user/password I created I could see a access denied response package. I created a user called wdtv with password P@ssw0rd. The strange thing is that in the details of the package I could see: “username: ssw0rd@servidor”. (servidor is the network name of my hp495 server). Something was missing in the password. The wd continued telling me “wrong username/password”. Then I changed the wdtv user password in whs to p$ssw0rd.01. The package now shows Invalid Logon, but the wd says now that the server could not be connected because was offline or something. Uhmmmmm. Ok. Then I changed the password to something like aA+12345 and voilá! I could access the shares!

So I thing there is some buggy thing about caracters @, &, $, %, etc… in a password to smb shares. As my whs is a kind of windows 2003, to see a share, whs forces a user to have a complex password, and that’s why I was using P@ssw0rd (very commom one). 

So if you have a whs in a hp495 and similars (i think) do not use those characters and you will be able to access your shares. You can create your user using the windows home server console as it gives all permissions a user needs or you can go to users and groups and do it yourself.

Ok, I am happy now :slight_smile:

Thank  TonyPh12345 for your patience and time posting the master browser post. That one was the beginning to all.

And sorry about my english, hope this post helps others.


Rio de Janeiro - Brazil


Excellent run-down.   Welcome to the Wireshark Fan Club.

Yes, you have proven a bug in the WD code; it should allow special characters.

I will post an ISSUE REPORT for you, here:


Please go “Vote” for it.

“Please go “Vote” for it.”