Wd tv live hdmi no signal problem and m2ts fiel not playing in composite format

I have purchased a WD TV  Live yesterday and tried to connect it to my Samsung B450 Series 4 LCD through HDMi cable. It says searching for signal and after few seconds it shows no signal. I have tried all 3 ports HDMI / Divx, HDMI 2, HDMI 3 if I switch off the HD live Device the screen shows check signal cable. Another problem is while playing m2ts file in component format  I get a message "1/1 Audio Channel AAC. Pls help!

Try calling WD support

You may have to use component / composite and set up your HDMI manually. It looks like your TV and the hub cannot connect automatically. (there is a HDMI handshaking problem with the live hub).

With regard to your second problem if you mean the black box that appears in the middle of the screen for some seconds when playing a video file, then that according to WD is a feature which some users want! If everybody complains enough then it might go away like it did on the WDTV Live.