WD TV Live HD - connection problems with Twonky - please help!


I used to have a WDTV Live HD connected to my WD Mybook Live drive via Twonky.  This always worked well.  A couple of years ago we had to change TV and ended up with a Panasonic which could connect straight to Twonky so didn’t need the WD TV Live.  However I have recently set up a TV in our bedroom and wanted to connect to the MyBook again.  I bought a WDTV Live HD again and managed to get it connected no problem at all to the network via a Netgear WN111 adaptor (finally found one that worked).

However, i have 2 problems:

When I select Network Shares, and then MyBookLive, it wants a username and password.  On my settings there isn’t a user name and password so i don’t know what to put in here.  When I leave it blank it just hangs on ‘connecting’.

When I try and select Media Server, nothing actually happens when I select it – it doesn’t do anything at all – completely unresponsive.

I spent hours and hours last night trying different things to get it to work with no luck and its driving me mad.

The Twonky version I have is 7.x which I updated about 6 months ago – so when I used the WD TV before it was on the standard installation on the MyBook which i think is 5.x?  I am happy to roll it back to see if that helps but don’t know how to do this.

I really hope someone can help me as my wife is giving me lots of grief over it.

Really appreciate it.

All the best

If you are connecting via network shares and you don’t have a username / password then you just leave it at the default shown.  You will have to go back into the setup up and clear the network logon and then try again with network shares. This time don’t change anything on the screen. Tick the remember me box and the tick box that’s all.

Thanks - will give that a go.  Just to clarify, when you say clear network log in, you don’t mean the wi-fi details do you?

Please excuse my ignorance if thats a stupid question!

Thanks again


Just tried that, but still doesn’t work - just sits on connecting and then comes up with an error message.

Just checked network connection and it ticked the first 2 boxes (IP address etc.) but put a cross against internet connection - is that anything to do with it do you think?

Really appreciate the help!


See if the first post in this thread can solve your problem:

How to resolve Network shares access problems

Thanks. Just tried it and still the same problem. What else could it be? Thanks so much for the help.

if it’s not able to get an internet connection, in theory you should be able to access your mbl

however it does indicate something is wrong with the network set up

which could also interfere with the ability to access your mbl

I would recommend first solving the more general network issue

are you trying to connect on automatic DHCP? or are you entering a static IP address and subnet??

first try auto DHCP

you also might need to reboot your router, if you haven’t done that already

You say in your first post that you’re able to connect to the network fine.

Are you able to use any of the built-in network apps without issue?  If not, then it is likely a bandwidth limit between your WDTV and your wireless router/AP.

Thanks for the help. 

I’m using automatic connection and the network apps don’t seem to work - just tried youtube and it hung the box.

For info, just checked my router settings:

My Home Network Devices currently connected to your BT Home Hub:

Wireless network: Desktop-HP      WDTVLIVE    

Ethernet: MyBookLive00:90:a9:b0:82:fd  

I’ve never had any bandwith issues before - if thats the problem, how do I solve it?

Thanks everyone for the kind help - much appreciated

Try it on a TV that’s closer to the router.   If possible, try using a wired connection, too.