WD TV Live HD & Actiontec router/modem [FiOS]

I recently switched to Verizon’s FiOS service and I can no longer connect to the internet with my WD TV Live HD box. I have an Actiontec MI424-WR router/modem. The WD box worked fine for the last year or so with my other ISP. I’ve seen some of the suggestions here on how to fix this problem, but I’ve had no luck. I have a wired connection and can see the WD box when I go to the admin screen of the router/modem.

Can someone please help me out?

Thank you!

Well, I can try…   I’ve been on FiOS for almost four years now.   Same router…  MI424-WR.  

What are all the IP parameters your MI424 assign to your WD Live?

Not 100% sure what you need, but here’s what I have for you:

Host: new-host
IP Address:
Subnet Mask:
MAC Address: 00:90:a9:73:76:b6
Network Connection: Bridge
Lease Type: Dynamic
Port Forwarding Services: None
Windows Shared Folders: \\\

Let me know if you need other info. Thanks so much.

That looks like the info from the ActionTec’s screen.

Look in the ABOUT screens of the WD and provide THAT information.

IP Address:

Subnet Mask:



It looks like your WD box has a default IP address and subnet mask (your router should be supplying this). Do you have your router set to be a DHCP server and automatically give out IP addresses to your devices?

I think so, but I’m not sure. On the main router admin page it says Connection Type: DHCP.

In the advanced settings >  IP Address Distribution it says:

Name Service Subnet Mask Dynamic IP Range Action
Network (Home/Office) DHCP Server -

Did you do this: go into the WD setup and choose Network Setup, choose Wired, then Automatic?

Yep. It couldn’t connect.

When I try to ping from the router admin page it fails, even though it shows as part of my network.

Is your WD connected DIRECTLY to one of the four Switch Ports on the FiOS router?   Are all the LEDs on both ends of the connection lit up correctly?  Try using a different cable.

It is plugged into LAN port 1 and the LED’s are on. I’m currently using the same cable I was previously using without a problem and believe I tried a different cable already with no luck. It seems like it’s got to be a router setting of some kind.

I’ve reset everything and changed the cat5 cable, but no luck. Now the WD box seems to be restarting itself randomly or locking up on the main screen. Anyone have any ideas?


Maybe you should try contacting WD’s Technical Support about this. You

can do so either by phone or email.

To Contact WD for Technical Support


I am experiencing the same problem on two WD TV Live Plus boxes.  One is hard wired, the other is wireless.  I just received a new FiOS router about a few weeks ago, and everything was working.  Now they will not automatically get an IP address.  I entered the network settings manually for the hard wired box and got it working, but once I shut off the device it lost the settings.  Just wondering if you got any further with this issue?  If I find a solution I will post it.  Thanks.