WD TV Live forgets IP settings


#1

My WDTVL connected to the Network via DHCP first.

Then it downloaded a new firmware and installed it.

since then - sometime it works but mostly it forgets its IP settings and they also can’t be set anymore (always 0.0.0.0 after finishing setup) then dhcp also doesn’t work.

I didn’t understand the system but sometimes it starts working when resetted or networkcable reconnected.

What can I do?


#2

Hi there, what is the current firmware you have? o.o


#3

I’ve the newest firmware.

I also had a look at the LEDs on the back - and they are dark when the WDTVL is not working via network.

I tried another port at the switch and a new cable.

other devides at the switch don’t habe a Problem with the same port and cable.

The 100MBit switch is connected to a devolo poweline-adapter and the other adapter is connected to the router.

tomorrow I will get a wlan-stick that’s reported to work. I will test it via wlan as well.


#4

I’ve personally never liked DHCP, and I avoid it like the plague (although I do understand that many people have no issues with it).

What happens if you try to assign a static IP to your WDTV and then enter those settings manually in the WDTV settings?


#5

after setting fixed IPs and pressing finished - same result, no network available. When I then look at the IPs I set, they’re all 0.0.0.0 again.

(I also don’t use dhcp)


#6

If the LEDs are DARK, then the network isn’t working.

If you’ve already ruled out the switch port and cable, then I imagine the ethernet interface on the Live is dead.