WD TV Live does not see shared Promise NS2300 NAS folders

The WD TV live does not see the shared folders on the Promise NS2300 nas. The Asus O!Play has no problem reading the shared folders on the NS2300.

Does anyone know how to solve this problem?

Hi ronaldsn, i have the same problem right now.

It`s written in the manual, that the wd live will prompt for a username and password, but it won´t.

There occurs just the message, that there is no media content found on this network share.

Has anyone got a hint?


Yeah, got it on myself.

You have to install the dlna addin from the promise homepage and everything is done.

Really easy.

I  played some time with some settings and solved my problem.

1- I switched off “Auto login to network share”

2- entered user and password for share

3- switched on “Auto login to network share”

Now I it is working without any problems

Miy WDTV Live does not prompt me for a password. Anyone know why please?

nehoma wrote:
Miy WDTV Live does not prompt me for a password. Anyone know why please?

Your network is not quite setup properly is your problem.

The following important steps should help.  The following guide directly applies to WINDOWS XP, but every principle of getting the firewall/router, windows services, and User Permissions setup properly are the key stumbling blocks that applies to all versions of Windows to be successful in networking with WDTV LIVE.

  • Make sure you have Network DDE DSDM and Network DDE set to automatic and started in your SERVICES. 

  • Also very important, make sure you DISABLE your firewall SERVICE in Windows.  Not the check box in Windows that disables the firewall.  That alone won’t do it.  You have to disable the actual firewall SERVICE called “Windows Firewall/ Internet Connection Sharing (ICS)” located in your SERVICES.  Don’t worry about your security.  That windows firewall is only good for LOCAL traffic.  It provides minimal to almost no security from the internet.  Having this SERVICE on could give you a headache with your WDTV LIVE.  And with routers nowadays, rarely does the average person need ICS either.  Ok, moving on…

  • Turn Guest account or a user(s) account you created to ON

  • In your router config settings, do not use the DMZ in application support (port forwarding).  Forward ports for each application or device in application support (port forwarding) instead. If you don’t know how to do that, don’t worry.  Here is a website that will guide you for your EXACT ROUTER/ROUTER MODEM YOU OWN on what exactly to do. Pictures are included for every single step of what you will be doing inside your router or modem/router settings.  This website is at  www.portforward.com.  Scroll down, select your modem and the rest you can almost do with your eyes closed.

This next part is optional, but may be necessary if you are also rrunning media servers/plugins. So, at the same website goto “Port List” and the same tutorials w/ pictures will guide you on opening up ports in your modem/router settings for your addons like Tversity for example, and Crackle, a Playon plugin, and other things you may have connected to your network.  Ok, we are done for the router settings.

Now you need to setup your USER PERMISSIONS.  Very important you get this right.  But beforehand you need to disable “SIMPLE File Sharing” by clicking…

. Scroll down and UNCHECK the box “Use simple file sharing”.

moving on…

-  Because most wouldn’t know which user or users to select to give PERMISSIONS to, just to be sure to get the right one, do the following steps below for each USER in your shared folder, and this needs to be done for each folder you want shared.

1 - Right click the folder  in Windows explorer you want to share on your network

2 - Then click on “sharing and security”

3 - Make sure Sharing is enabled

4 - In same window click on PERMISSIONS

5 - Then click on ADD

6 - Click ADVANCED

7 - Click FIND NOW

8 - Highlight first USER you see

9 - Click OK

10 - Click OK again

11 - Now you are back in the PERMISSIONS window. Select the USER that was just added to the PERMISSIONS window and ALLOW all the permissions by placing checkmarks in the ALLOW boxes.

12 - Now, do step 5-11 and repeat steps 5-11 until all users are added.

Then reboot the modem/router first because of the changes made, then the PC or PCs, the WDTV LIVE in that order. After that it won’t matter which order you boot up unless you make drastic changes as indicated above.

Doing all these steps should resolve just about every network issue you may have with WDTV LIVE connected to your network.  Let me know how well you did.