WD TV Live does not refresh files from NAS drive


#1

This has happened to me a couple of times.  I will reorganize video files that I have on my NAS drive by adding new files or changing file names and when I scan through available videos it will still show the files, but in their old locations.  When I click on the actual files it gives me an error message on file type being incorrect.  When I rename the files to the old names or put the files back in their old configuration, the files will play.  The WD HD TV live does not seem to refresh to see whats actually on the NAS.  When I use the file management function though on the WD, it shows the updated configuration.  Its only when I try to play the files is where the listings of the files and file names do not refresh. 

Any ideas on what could be causing this?


#2

Hit the HOME button, and go back into the share. That should take care of it.


#3

Didnt work.  I typically search for my files under    video/media server/myworldbook…and then I search “by folder” because all my folders are organized in that way.  At that screen is when the folders showing on the WD are not what is actually on my share.


#4

dmcshea wrote:

Didnt work.  I typically search for my files under    video/media server/myworldbook…and then I search “by folder” because all my folders are organized in that way.  At that screen is when the folders showing on the WD are not what is actually on my share.

If you look under media server then its the media server on your NAS that is not updating. The media server is the one that serves the files.


#5

But it shows up fine under file management on the WD.  just bad when I try to search and play the files.  on all the computers that are on the network…I can see the files updated properly.  I’m thinking it must be something on the WD.    Is there something that I can check to make sure that the NAS is working properly?  Is there something I can refresh on the WD without actually resetting the box?


#6

If you are using the MEDIA SERVER menu, then it’s the fault of the MEDIA SERVER. File management menu does NOT use the media server function of your computer.


#7

With it being a 2TB WD NAS drive…is there anyway of troubleshooting the drive through my computer or something else?


#8

You’ll need to consult the documentation for that drive to learn how to ReScan the media. It’s probably accessible through the Web interface for that drive under the Twonky configuration, I’m guessing…


#9

Try this:

Go to  - Setup / System / Media Library / Clear Media Library

This will refresh all media in the currently selected share.


#10

Ron_F wrote:

Try this:

Go to  - Setup / System / Media Library / Clear Media Library

This will refresh all media in the currently selected share.

    • *that only applies to USB drives, not NAS.

#11

You might want to try accessing your NAS files thorugh “network shares” rather than “media servers”. I was going nuts trying to find my DVD ISO files until I read about using network shares to get DVD menus to work.

With my Netgear NAS, I had to set up a “media share” that pointed to the media directory with attached subdirectories.

When my NAS file changes don’t seem to show up properly, I cycle power on the WDTV Live then reconnect to the network shares.

Hope this helps…