WD TV Live Constantly Crashing


I bought the WD TV Live back in September, and have had problems with it ever since. It would restart randomly during playback, playback was laggy and sometimes the video would freeze and the audio would continue, or sometimes I would play a video and the sound would start but the display still shows the folder menu and never actually plays the video.

Anyways, I filled out an advanced RMA form and got the replacement today. The replacement device will not boot past the WD TV Live splash screen, with the clouds and space or whatever. It shows this screen for a few seconds, then the signal cuts out and my TV displays the “No Signal” message as if nothing is connecting.

How can I fix this? I have restarted it several times and tried connecting it through RCA as well as HDMI, and both of them have the same issue. I don’t even know how to update the firmware, since WD’s instructions require the device to be on.

Also, the replacement remote is discusting. There is dust/hair in between the buttons, and the buttons are kinda sticky when you push them down. Probably some of the worst service I’ve ever seen. Definitely will be my last purchase from Western Digital. Shame, since I usually go to them for hard drives.

I assume that you are waiting when the no signal message comes up as this is part of the booting process. If you wait for some time and nothing happens particularly on composite video then send it back again.

1 Like

Yeah, I noticed that it does that on my old box, and hoped it would do it on the new one as well. I left it on for about 5 minutes for both HDMI and composite with no luck.

I contacted support to create a new RMA. Problem is that I chose advanced RMA, so I currently have two boxes that need to be sent back. I really hope they don’t make me ship them back separately.


WD Sent me a replacement box, again. The box turned on but is stuck on the WD Logo screen, with the sky background.

I have let it sit for ~10 minutes and the screen hasn’t changed. I tried restarting the unit and now there is no display at all, and the TV says “No Signal”. I tried using the reset button with a paper clip and that didn’t help.

Any advice…?

Do not connect anything to the box except the power supply. Connect via the composite lead suplied.

I tried that, and I used two different composite cables.

The HDMI connection worked initially, but as I mentioned the box was stuck on the logo screen and after I restarted it, there was no more display.