WD TV Live C3H - Movie Image Frozen on screen even after power off

Hi All,

I was watching a movie as normal from a NAS when the image froze and the audio continued playing. The remote control had no effect so had to pull the power. I left it 30s and powered back up only to return to the same frozen screen image, but with no playback audio. Again the remote did not work. Tried pressing the reset button for 10+ seconds with no effect.
Any ideas?

Many thanks

pull the power or reboot your NAS would be the second thing i’d try …

it’s most probably a (or ‘the’) DLNA /UPnP glitch (assuming your using media shares … and not network shares)

Here’s some fun i had with it … serve a video via DLNA / UPnp, hit the Option Button then the Home Button on the Remote and “Presto” you’ll have Video Playback in the Background via the user interface … not the exact same bug you have, but it’s most probably “related”

Basically you need to reset the Media Server, as you found resetting the Client does nothing.

I’ve rebooted the server and even updated the firmware. The WD box still powers up showing the same frozen image.

If I disconnect the Ethernet cable and restart it still shows the frozen image.

Restarting the WD without Ethernet and with a USB stick results in the same frozen image.

Is it poss to reflash the firmware at power on - and would that help?


Tried the WD on a different TV and it was fine?? Went back to the original TV switched it off - then on. Reconnected the WD and started it up… Back to normal.

Therefore I assume the TV’s HDMI circuitry has a buffer which had become corrupted with the frozen image & restarting the TV fixed the issue!

I honestly thought i’d bricked it… Thanks

Weird, i have never heard of that happening with HDMI ? Anyways, as long as it’s sorted :slightly_smiling:

Yep, I was about to tell you to turn off the TV, until I read that you did. This happens with a Chromecast often and with either one I have. In this case it is caused by the Chromecast, although I have seen once or twice happen with my WDTV and TV. Stuff sometimes is not flushed by buffers, and this is one of those cases.