WD TV Live and Mac Computers


#1

On the forums I’ve been reading a lot from PC users networked to WD HD Live but have yet to see discussions of how Mac users are using their WD HD Live.  Would be great if we could share information.  So let me start…

I love my WD HD Live as it does everything it says it does. I was able to get iPhoto working by connecting to the iPhoto Library on the Network Preference Pane/SMB by selecting the Library and control+click> “Show Package Contents” and added (dragged) the modified photos folder to the SMB sharing window.  My best experience is using the media server Yazsoft’s Playback which greatly improved large MKV and TS HD files. A good deal for $15 bucks–really improved the experience.  It only supports one iPhoto Library and won’t transcode my years of DV files.  It also doesn’t have Hulu or Netflix. Would be nice to have the PC server PlayOn or TVersity ported to the Mac.  I’d pay $50 for a copy of those.  What are other people using? any problems? or what has been your experience using the Mac with WD HD Live


#2

Hi, I’ve just tested yesterday sharing a media folder using SMB. Worked fine until it suddenly disconnected, but I was running a  f i n k  install of mediatomb and recording a DVD. Too much at the same time ?

Anyhoo, I’ll check mediatomb and decide on it or on using filesharing via SMB.

I’m still looking for a way to share my iTunes library directly.

I can see and connect to a usb flash drive and a 500GB HD connected to WDTV-Live. File transfers to them are slow though.

—  writing f i n k , the package manager gets me a *bleep**??? lol


#3

Playback (from Yazsoft.com) is the only reliable uPnP/DLNA server for the WD TV Live that I have found. Certainly if you want to watch TV-recordings made by EyeTV.

Others like Eyeconnect do not work at all correctly, Twonky is a disgrace to see, Medialink does not start up.


#4

The reason why more Mac users don’t post may  be because they’re still trying to find out how to use the d____d thing. It took some research and trial and error for me to find out that the local server (USB drive) had to be formatted using Master Boot Record (MBR) in order to work with HFS+.

I’m stilll trying to get the WD TV Live to connect to my computers. It sees both computers, but gives me “There is no media in the current folder” for my iMac. Well, I put media at the root level of the boot drive so I’m not sure what folder it means. However, this iMac is running OS 10.4 (Tiger) and I understand that may be the problem. It’s a small problem in any case as I use my MacPro for most media work.

My MacPro is set for file sharing (SMB & AFP) but the TV Live says “This server cannot be accessed.” I have tried every permutation I could think of and still get that message. Fortunately, I can access the local drive from the MacPro so can transfer files for viewing. But the inability to access my computer is disappointing, to say the least.

Any ideas?


#5

Get yourself a trial version of Playback (yazsoft.com). And all should work.


#6

I had the “connecting…” msg before yesterday.

I don’t know what changed, it was working a few days ago. Last night when I came back, started up my iMac (10.5.8) and the WDTV-L checked the network settings (same IP) and it took a little while but the files showed up.

SMB working again.

Who knows what causes those delays. I will try with static IPs next time as part of TS.


#7

I tried your suggestion and “should” is the operative word. .I get the same “This server cannot be accessed.”

Playback could see the the TV Live as can the computer. TV Live can see the computer, but cannot access it. BTW, I tried turning off the password requirement on the computer and that did not work. I turned it back on.

I’m going to try Playback on the iMac and see if that works.


#8

There are 2 ways to access files from WD Live on a Mac.

The easy way:

Install Playback and tell it which folders you want to see on the WD. PB will take care that you see movies and not any rubbish. No sharing or whatever difficult stuff

The difficult way:

Use Network (AKA Samba). Define on the Mac which folders are to be shared and for which users. On the WD you now have to work thru the folders eliminating all the unwanted files (like hidden & other rubbish). Make a (small) error and you will see nothing.


#9

It takes a little more work than dropping files into a root directory. You need to go into System Preferences>Sharing and turn SMB On then add the folders you wish to access to the SMB sharing window.  I set up a folder called Video Server in my user Movies folder and put all the videos I want to share in there–and dragged that Video Server folder to the SMB sharing preference pane window. Again, the easier way for $15 is to use Yazsoft’s Playback. You still have to tell it what you want to share and where the files are but it takes care of the rest.  


#10

I think that Playback really grinds the HD on my iMac. Since I’ve replaced the HD twice this bugs me. I’ve had like nil problems just turning on sharing. It exists peacefully with the AppleTV and all.

Playback does work though but I’m not impressed with it much.


#11

I’ve done a lot more than drop a file into the root directory on my iMac in response to the message; “There is no media in that folder.” That was just one stop on my journey. I installed Playback on my iMac and idenified the folders to share and still had no luck. I suspect that the problem is that it is a Power PC rather than Intel so I’ll just focus on my MacPro for this post.

I started by setting file sharing for “All Users” by SMB as well as AFP. No luck. Without changing those settings—in response to a suggestion on this forum—I installed Playback on my MacPro and identified both the dedicated media volume on my MacPro and the subdirectories (folders) in it to be shared folders. The problem seems to be with computer access, not volume/folder access. The MacPro is shown in the TV Live menu but, upon trying to access it, I get the message: “This server cannot be accessed.”

The fact that I can mount the TV Live on my MacPro and transfer files to it makes me suspect that the computer passwords may be the problem on both computers. But I don’t see any way to put the passwords into the TV Live and cannot believe that using that device requires me to run my computer without a password. In any case, I tried removing the password requirement from the MacPro and the message didn’t change. I have just about run out of ideas and will welcome any proposals that I haven’t already tried.


#12

Try setting it up so that the shared folder is password protected.  I had this same issue (Ubuntu 9.10, ext4) but it went away as soon as I required a password for the network share.


#13

what is working for me is:

-WDTV-L with wired connection to router
-iMac is connected via 802.11g
-SMB enabled only for the account where my media is

-had to enter that account password to enable SMB
-AFP is off (on or off, works the same)
-add media folder to share (in control panels>sharing)
-guest account is enabled
-guests have read access to my media folder

After a hickup where i got the “connecting…” msg without connecting, I set a static lease in my router so that WDTV MAC is always assigned the same IP.

No issues after that.

I’ve even streamed 1080p over G but with some hickups… seems to be too much for a g network.


#14

Computer and WDTV are hard wired to the network. I can see the computer from the WDTV but cannot access it. I have listed the shared volumes; authorized WDTV as a  user and entered the passwords for my account and for WDTV  under SMB.

I still get the message: “This media sever cannot be accessed.”

Is it possible that this is because the drive is not FAT formatted?

OK–Problem solved. I couldn’t see how to enter a password into WDTV until I read on the forum that one had to turn off Automatic Login to get the screen that allow the user and password to be entered. After that, Automatic Login can be turned back on and all now works as advertised.

I don’t know whether to be ashamed or angry at the inadequate manual.


#15

The WDTV Live works superbly for me with an iMac (and Macbook Pro), Time Capsule (dual band) and an Extreme base. WDTV is hard wired to Extreme which connects wirelessly to Time Capsule. I couldn’

t see files on the Time Capsule until I realized I had not specified the 5 GHZ network (in Airport Wireless advanced settings…choose that name as yor network) as my network…now the WDTV sees and plays all files on my Macbook pro, iMac and Time Capsule without a hiccup.

I think most issues with WDTV network stuff is improper user network/airport/wireless settings because this thing, when hooked up properly is dynamite.


#16

I would like to figure out how to stream internet radio from my iMac to WD live. I am serving the WD live with SMB enabled. I tried twonky but it is unstable.  Otherwise, I can watch HD and play iTunes and look at iPhoto. 3 stars out of 5.


#17

Can anyone tell me why i cant open any files while using Playback?

I cann access my HDs connected to the MacBook, but those files wont open, any ideas?


#18

Hello,

please help me -

I have the new HD TV live network one,

Have a mac, the hd tv live can not see the computer - the computer however can read the external drivers attached to the hd tv live.

please help have tried everything I can think of -

sharing is on etc

thanks

mark


#19

Hi Guys

I found this guide on how to setup your mac for the WD TV Live.

Worked fine for me after this :slight_smile:

http://www.youtube.com/watch?v=6kLB7B7vChk&feature=PlayList&p=BDB3A9857F4DB9F3&playnext=1&index=8