WD TV HD Media Player doesnt play anything


#1

Hi all,

few days ago I watched som mkv movies on my WD TV HD Media Player (Gen 1, FW 1.03.01 (11/2009)). Today I switched it on, try to start a video file to play, but only black screen… no video… no sound…

It is not a media file type problem, because I could play them few days ago.

Tried to reset to factory defaults, but it didnt help.

Menu is working good, but after choosing a video file, the screen goes black, “stop” button doesnt do anyithing, only way is to push the “back” button.

Strange, but maybe someone can help me please…

THANKS!!


#2

You’ve played an .mkv with compression in the headers.

You’ll have to re-mux it with compression turned off.

http://community.wdc.com/t5/WD-TV-HD/WDTV-HD-FAQ/td-p/66636


#3

Thanks, but I wrote, that the problem is not with compressed file or not. I tried to play files that I have watched few days ago with the same player, from the same USB HDD.


#4

Once you play a compressed-header file and the box gets confused, then it won’t play ANYTHING… even files that had played in the past.


#5

What do you mean with “the box gets confused”? Is it dead? No possibility to use again???


#6

It’s not dead, it just takes some effort to get it un-confused.

For most people, leaving it unplugged for 10 minutes, then selecting “Reset To Factory Defaults” in the settings, then once that’s done pushing the paper-clip reset button next to USB1, has been enough to unconfuse it.

For me, even that wasn’t enough.  It didn’t start working again until I’d left it unplugged for 24 hours.  Then it would play again until I played another file with compression in the headers, and then again wouldn’t play ANYTHING until it was reset.

So, at that point I stopped letting MKVMerge use compression when I made my encodes, and went back and “fixed” any that had compression.


#7

Thank you very much! I am going to try your advice! I will let you know…


#8

You were right. After a few hours works my player correctly.

… and I found that file with wrong compression and remuxed it, now plays OK.

Thanks again!


#9

Similar issues here. Luckily I unplugged it from powr this morning before going to work. Will check the mkv file which is causing problems and remux and then will try it again tonight. Thanks for the info.


#10

I have similar problem. It won’t play anything saying that video cannot be played, and that i have to check supported formats. I tried with videos i watched but it won’t play anything. Do I have to try the same method or it is unknown issue for you. Thanx.