My WD TV 1 is dead.

It’s been more than a year now since I purchased it and the warranty is over. The box works fine but it slowly degrades as time past. Usually black/ green screen appears if we use continually. Before it may last up to 10 hours but lately about 2 to 3 hours only just enough for one movie. Then one day, after watching on it and properly closing ang unplugging it, the next day, it just wont open. I’ve checked the battery of the remote and it seems to work( there’s no way to know since there’s no power button on the device itself). There are no loghts, no heat, totally dead as if it’s POWER OFF.  Is there magical power button hidden on the device? Is there a way to revive it?


You tried the reset button?  On Gen 2 it’s located near the side USB.  A small hole, big enough to get the end of a paper clip into.  Put said (uncoiled) paper clip in and you should feel a button go.  Power on again.  It doesn’t sound promising, mind.  Usually above routine works with a ‘stuck’ system.  Worth a go, anyway.

To chris110761,

Yup, tried the reset button but it still doesn’t work. I checked that processed and may only be applicable if the device is turned on. It seems that the device is turned off.

Is it advisable to open the device.If so, how?


Maybe someone else might advise different, but I think your device might be finished.  The black and green screen suggests the processor is at fault, but I’m no expert on the inner workings of the live.

It works now! i don’t know what happened but after 2 months we tried it again and it works. however, it’s having the creen screen after few minutes of watching, sometimes it doesn’t. If indeed it is because of the processor, what can I do about it? do you have any idea now? thanks