WD TV freezes compiling My Book 3TB drive media

Which firmware?


What happened?

WD TV SMP started freezing minutes into compiling media from My Book 3TB. Both the lights on the WD TV and 3TB HDD blink while compiling, a few minutes in, the HDD light goes solid and the WD TV light continues to blink. The unit is frozen at this point and only removing the A/C will unfreeze.

what were you doing?

Trying to compile media.

Does this happen every time?

It does now. Everything worked perfect until a couple days ago.

What hardware and media were you using?

WD TV SMP and My Book 3TB

Did this happen with previous firmware?

No, but I rolled back to 1.11.14 and the same problem occurred.

Does power cycling the unit solve this?

Yes, until I try to compile the media again.

Does resetting to factory defaults solve this?


Have you tried this on other devices?

Drive works fine on all other computers and the WD TV SMP works standalone and with small usb thumb drives.

Any help would be much appreciated



Test the drive with DLG to see if is an issue with the drive it self?

Are you able to test the media player with a different drive?

This way you will know what is causing you the problem.

Did you check the drive for errors?  Unmount it from the WDTV, plug it into a PC, and run chkdsk on it.

Did you add any movies recently?  Try removing them in case one of them is causing the issue…

Are you using the front or rear USB port on the SMP?  The rear USB socket has been known to have  problems with USB3 drives.