WD TV, Asus RT-N66R, WD MyBook Essen. and MyPassport

Soooo…I’m sure this has been asked - I’ve dug and can’t find an answer. I’ve tried a few things that SEEM related with no luck.

I’m running (as the title shows) an Asus RT-N66R, and have plugged into it a WD MyPassPort 2TB and a WD MyBook 2TB and two WD TV’s. All are running latest firmware. I’m not sharing anything via Windows/Linux/MAC/Other.

In the Asus GUI under “Network Place(Samba) Share / Cloud Disk”, I have the folders I want shared with Read only or No (only the admin has full access). I’m using a user name of “wdlive” and to simplify until the problem is figured out, a password of “1” for the shares.

Now, via Windows 8.1 I can access the folders with either the wdlive or the admin account, zero issues. However, when I try to access the share via the WD TV “Network Shares”, it SEES the router and prompts me for a user name/password, and all I ever get is “Unable to connect to the network…” error message, regardless of what user name/password I use.

I’ve done everything I can think of short of using “Guest” access (not an option, I have leaches in my neighborhood so while you cannot 100% shut them out, I’m doing all I can on my end).

The main reason I’m wanting to connect this way as opposed to using the DLNA Media Share is that while I was running a LinkSys router just recently, the whole Media Share would shut down every 30 minutes while watching a movie on the WD TV. I would lose the LinkSys media share AND my DirecTv media share (thus why I think the problem is in the WD TV, not the LS). In a hopes to troubleshoot the system, I’ve opted to replace the LS with the Asus today. I’m using the same WD TV to run the same movie via the Media Share and (knock on wood) so far, it hasn’t shut down. However, I don’t have 100% faith that the WD TV wont begin stopping again every 30 minutes so I’d like to run this all via Network Shares (NS because none of the laptops ever have this 30 minutes issue).

Suggestions, tips, pointers to other articles are HIGHLY apprecaited (before I toss these devices off a bridge)


Try setting up an 8 character password for the share.