WD TV 1st GEN no digital sound to my AVR anymore


#1

Hi, I have for quite some time a 1st GEN WD TV with latest firmware.

Video is connected to my plasma tv via hdmi and sound via toslink to my amplifier for DD and DTS sound.

Worked all fine until now when I play an mkv movie video is fine but the amplifier does not switch anymore to DD or DTS.

Settings checked - Audio is Digital.

I have reset the WD TV 2 times now via the menu.

Anybody with same problem and a solution ?

thx,


#2

How did you create this MKV file that doesn’t work?   Did you use a version of MKVMerge greater than 4.0?


#3

Hi, it doesn’t matter which mkv movie I use (they all played ok with video/sound before) but since today my receiver does not switch anymore to DD or DTS so no sound anymore …


#4

I understand, but did this begin when you tried to play a NEW MKV file?  Or has NOTHING changed?

Try:

  Press the RESET button.

  Then, do a FACTORY RESTORE from the MENU

  Then, UNPLUG it for a little while.

Then restore your preferences and try again.


#5

I will try what you suggest. But nothing has changed …


#6

Do I have to push the reset button when it’s on and then to a reset ?

If you say unplug it do you mean do disconnect the power and all connections ?


#7

Yes, push the reset button when it is on.

Also, only need to remove power, not the rest of the connections.

If that doesn’t work, check your A/V cables.  


#8

Ok, all did what you suggested but no luck.

I will buy a new toslink cable. Is it possible that a toslink cable suddenly stops working ?

When I try my DVD player with coax digital cable all works fine.


#9

Sure, if it got bent or squashed, the plastic fibers can break.  Do you have another optical device to test it with?


#10

There is a Bug in the Digital/Stereo toggle switch in Gen 1 WDTV.


All you need to do is - Go to settings- Toggle to stereo, come out of the menu. Go back in and toggle to Digital. You will start getting Digital sound for sure…  Its works for me.