WD Sync not syncing but says "WDMyCloud is up to date"

I discovered that WD Sync stopped working some months ago and have tried all sorts of things to get it working again, but it still won’t sync anything.

When I right click on the WD Sync icon it says “WDMyCloud is up to date” - but no files are syncing.

I’m running Windows 10. I’m using the latest WD Sync (1.3.5949). I’m on the same network as my MyCloud. I can connect to my MyCloud device via the network and view the files on there without any problem. I can save files to my MyCloud and there is 890GB space available. My MyCloud has the latest firmware - WDMyCloud v04.05.00-315 : Core F/W.

Things I have tried:

  • Paused syncing in WD Sync. Then resumed syncing. It did a recount of the files it needed to sync (2575) but then didn’t sync any. A notification appeared saying that is couldn’t sync a file. I paused and resumed again, and it gave the same notification for a different file. Nothing else synced.

  • Quit WD Sync and restarted. Didn’t work. Still said 2575 files pending.

  • Deleted a folder pair, and re-created it. Didn’t work.

  • I removed the device and re-added it. Still didn’t work.

  • Deleted WD Sync off my PC. Then reinstalled it from scratch. I setup just one local folder to sync (in addition to the standard “My Cloud” folder), and still nothing syncs. It now says, “WDMyCloud is up to date” but nothing syncs across.

  • I removed the device again. Then I went through the steps to add the device and I logged into my MyCloud account in WD Sync, instead of just using the local network discovery. But this didn’t change anything - it still doesn’t sync. Still says “WDMyCloud is up to date”.

  • Quit WD Sync (the new installation) and restarted. Still didn’t work.

Please let me know what else I can do to get WD Sync working again?

Thanks
Josh

Hi,

Check your firewall or any antivirus settings. Otherwise, I would recommend that you contact WD Support.

Was it resolve? I have the same problem too.

No, never got it solved unfortunately.

I experienced similar issue on Windows 10. I read in a 2015 (or something) post that turning off USB Content Availability could solve the issue. And it actually did, as soon as I turned it off, the WD Sync magically started working again. Hope this helps someone

1 Like

I got the same issue lately - and have tried the same as Josh.
WD Sync does not work

Which is why some have moved to using third party sync programs instead. Some of us here use Free File Sync (https://freefilesync.org/) instead of WD Sync. May take a little more time to setup/configure but works well and doesn’t have the various issues may have complained about, like the hidden WD Sync folder sucking up all the free storage space on the My Cloud.

1 Like

@fleanez It worked! I turned off USB Content Availability, as you suggested, and I experienced the same thing - WD Sync immediately started working. Thanks.

Looks like a clear bug that WD need to fix.

Dont Worry! About it… Just make sure the drive is working properly solid blue LED. Connected to same internet network no extended network. Map the drive 1st.

Now Access the dashboard of the mycloud. Goto<user<set enable cloud access.
Register the drive with userID and password.

Now download the WD SYNC and set the drive. make sure all smb setting is enable from the Window turn on/off feature. It will help to prevent network blocking.

Once Done your device will be ready for Sync…

IDK, I have the same problem, and i’ve been playing with it for two days. I think im gonna go the freefile sync route. this is too difficult for me.