WD Sync not syncing but says “WDMyCloud is up to date”, only on Windows 10 client

When I right click on the WD Sync icon it says “WDMyCloud is up to date” - but no files are syncing. things I have tried: Paused syncing in WD Sync. Nothing else synced. Quit WD Sync and restarted. Didn’t work. Deleted a folder pair, and re-created it. Didn’t work. Removed the device and re-added it. Still didn’t work. Deleted WD Sync off my PC. Then reinstalled it from scratch. I setup just one local folder to sync (in addition to the standard “My Cloud” folder), and still nothing syncs. It now says, “WDMyCloud is up to date” but nothing syncs across. I removed the device again. Then I went through the steps to add the device and I logged into my MyCloud account in WD Sync, instead of just using the local network discovery. But this didn’t change anything - it still doesn’t sync. Still says “WDMyCloud is up to date”. Quit WD Sync (the new installation) and restarted. Still didn’t work. Tested on the 2nd PC/Laptop, still the same. All Windows firewall are turn off, no anti-virus, PC and My cloud are on the same network, same router. I can access via WD Access. All my Windows 7 PC/Laptop are working fine

Hi lambert,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.

I got the same problem. Tried everything. Nothing works.

Finally, I got it to work, but it is not thru the WD support team, they only cut and paste the standard answer from the FAQ.

  1. Uninstall everything and patch up Windows 10 to the latest. Check windows or any firewall does not block any WD software.
  2. Ensure you WD Mycloud is at the latest FW, but seem WD has not updated the FW since Sep 2018.
  3. Now for the first time setup, make sure your client PC and My cloud is on the same network (connect to the same router), use your windows network to discover your WD my cloud, you must be able to see the WD my cloud first before you proceed to install WD access and WD sync.
  4. If possible try to log in to WD my cloud using “net use” command and map a network drive, or at least able to ping the device, the basic is your windows SMB must be working.
  5. If you can get thru step 3 & 4, proceed to install WD access and WD sync, it should work fine.
  6. Now you can try using a different network to test out WD sync.

The WD sync is still very buggy, very offer WD sync will show your device is missing, this happens if you switch network or disconnect/reconnect back, what you can only do is reboot your pc

Another big bug, with the new update FW, you now can only reboot the device, you can’t shut it down, because the option was being removed.

Personally I am very disappointed with WD my cloud, I am looking at other product to replaced it.

Yes WD Sync is buggy. There are numerous complaints about that software that can be found using the forum search feature (magnifying glass icon upper right). If one doesn’t need syncing to a remote off site My Cloud, then do what many others have done. Use a free third party program like Free File Sync (https://freefilesync.org/) and dump/uninstall the buggy WD Sync program.

If you have a second generation v2.x single bay My Cloud, WD removed the “shutdown” option from the v2.x single bay My Cloud Dashboard a loooooong time ago. If one uses the forum search feature one can find numerous past discussion on that shutdown issue, and workarounds to it by using SSH to call the shutdown command.

But what is the point of buying a Cloud device that doesn’t work, WD don’t even bother to fix it and the tech support actually ■■■■.

I gave up on the WD sync awhile back when I found out it did not sync all files defined on my Win 10. I now use Google Backup & sync for cloud and for local to Mycloud I have SyncToy with multiple mapped pairs and run it via task scheduler.

I found in another post a solution (for me at least). Disable the “USB Content Availability” in My Cloud Dashboard, it solved it for me and started to “really” sync.