WD Sync no longer works on my iMac

For years I used WD Sync on my iMac (Macos 10.14.6) and my Macbook Air (Macos 10.14.6) with my WD MyCloud hard drive without any problems and synchronized folders with it.

A few months ago I exchanged the hard disk in my iMac for a faster SSD . I had to restore the system and all software from a Time Machine backup.

Everything runs fine, only WD Sync doesn’t work anymore. I simply can’t install WD Sync anymore, I get the error message “WD Sync Installer ended unexpectedly”. I downloaded the installer fresh from the WD homepage. I tried the following steps without success:

https://support-de.wd.com/app/answers/detail/a_id/21115/initiator/user 2

WD Discovery installed, and I sent the logs and other logs to WD’s support, who couldn’t or didn’t want to help me either.

WD Sync on my Macbook Air still works fine. I don’t know why I can’t reinstall it on my Mac. Support advises me to just sync without WD Sync and sync the files with third-party software instead.

But WD Sync ran great, I would like to use it and I don’t want to spend money on the sync software again.

Does anyone know how I can reinstall WD sync on the Mac?

Best regards,

Jacques

PS: I can access MyCloud via the web browser, that works without problems, only WD Sync doesn’t work.

After a long research on the internet I solved the problem: The cause was that the font “Arial” was no longer activated on my iMac. Since I activated it in the App “Font Collection”, WD Sync is running fine again. I post this here as information for all those who might be facing the same problem. It’s a pity that the so called “support” from WD hasn’t led me in that direction.

I have the WD My Cloud app, but it won’t allow me to enter my user name. I can enter the password, but the username field won’t accept any input. Feb 2020

If by WD My Cloud app you are talking about the My Cloud Desktop program, that program has been end of life since 2016. And no longer works after recent firmware upgrades to the single bay My Cloud line. WD has a Knowledgebase article covering the WD My Cloud Desktop program no longer working.

My Cloud Desktop App No Longer Works with a My Cloud or Login Not Authorized
https://support-en.wd.com/app/answers/detail/a_id/25159