WD Sync can't work,It keeps prompting “not connected to the Internet detection”

I hope to sync my documents online, between my laptop and my cellphone.

So WD MyCloud and WD Sync for Windows is my best choice, which was working good for serveral months after I got them setuped.

BUT, Two months ago, It just stops working…

The WD Sync for Windows in my laptop keeps prompting”No Internet connection detected". and never syncs files or make any changes when I delete a file.

I tried everything to make it work. And I notice other guys in this Community had the same trouble.

So My question is:

What should I do?

DOES the engineers of WD know the situation of our users?

Any direction is warmly received. Thanks a LOT!!!


S01, WD MYCLOUD is working well. (the S02-S06 proves that )

S02, WD SYNC for Windows in my laptop is the latest version 1.3.5949

S03, I can login in and manage my cloud VIA " #Local NETWORK IP ADDRESS"

S04, I can access all the files and create\upload\delete files, on my laptop VIA “https://files.mycloud.com”, also, VIA "https://idp.mycloud.com/ " and “https://wd2go.com

S05, I can access all the files and create\upload\delete files, on my laptop VIA the software “WD My Cloud” (latest version )

S06, I can access all the files and create\upload\delete files, on my cellphone VIA the APP “My Cloud” ( both IOS and Android, latest version, both local network\internet, even LTD)

S07, The network which the WD MYCLOUD connects is good. ( the S5-S6 proves that )

S08, The network to my laptop is good. (that’s obivous, how could I post these words? )

S08, I tried to reinstall the windows 7 in my laptop, and reinstall the WD SYNC software.

S09, I tried to reset my WD MYCLOUD, and used the software “WD Sync Setup” to config the MYCLOUD.

S10, I tried to install all the WD software, like"WD_Quick_View_Setup"、 “WD_SES_Driver”、 “WDMyCloud_win”.

S11, I live in CHINA, SO, I tried use VPN on my laptop, switched the server in USA、HONGKONG、JAPAN、SINGAPORE、TAIWAN, them all make the laptop can open the sites, like: FACEBOOK, TWITTER, INSTAGRAM, YOUTUBE, GOOGLE

S12, I tried to connet the WD MY CLOUD to a VPN network, to make sure the link between My CLOUD to the WD servers is NOT blocked.


When I start WD Sync, the status (in sys tray) will go like this:

  1. MyCloud;
  2. Signing
  3. No internet connection detected

Why am I getting the "No internet connection detected” when I clearly have internet connectivity ?
I suspect the possible reason is: Sync Wd this software has BUG.

WHAT EXACTLY DOES THE ADDRESS “device1091669-721ac7fe.wd2go.com” DO??? I can login in wd2go.com, but I can’t login this stuff !!!


Try to remove the device from WD Sync, then restart your computer. Once restarted, open WD Sync and add the My Cloud again.
Pause and resume the syncing using the icon on the tray.