WD Sync cant seem to find the My Cloud device on local network

Win 10 laptop (1607)
WD 4Tb My Cloud \ firmware 2.30.165
Both devices are connected to the same Ethernet hub.
Both the laptop and the My Cloud device are members of the same Windows 10 work group.

Everything seems to work fine with the My Cloud device except for an issue I am experiencing while trying to install and set up the WD Sync app.

During the installation process, when I see the "Select your My Cloud storage device dialog, it reads “No storage devices were found”.

Step 4 of the following WD document indicates that “the process” will auto discover the My Cloud device on the local network.

That however, doesn’t seem to be the case.
Anyone know why this is occurring and what I might do to fix this ?

Of note:
All the time while the above installation process is occurring I can access the My Cloud device by logging on as admin or simply by clicking on desktop shortcuts to the various shares on the device.
So, I’m thinking the device itself is healthy.

On the same dialog, if I click on “Sign in”, and enter my MyCloud.com user ID and password, the dialog then does actually find my My Cloud device and if I then click on the “Next” button, WD Sync seems finishes the installation\configuration process and I am able to sync file and folders just fine.

Additionally, for testing purposes, I removed my router from the mix of equipment involved.
So all I have is my laptop, and the My Cloud device plugged into the Ethernet hub.
I also turned off the firewall and disabled my virus software
Of course I can’t use the “Sign in” option then but more importantly, the WD Sync install\configure process still doesn’t seem to be able to auto detect the My Cloud device.
So, I’m pretty sure the router, firewall and virus software is not the issue.

Thanks
Ray in Wisconsin

Hi Ray, I haven’t really tried to install the WD Sync. Let’s see if anyone else in the community has done so and encountered the same issue as well. In the meantime, try installing WD Sync on a different computer, if possible, to see if the same thing happens.

K. I can do that. As aside, WD support asked me to repeat the failure and then generate a log and send it to them. (Which I did.)I’ll installing it on my wife’s pc shortly and then let you know of the results. Thanks for replying.

I haven’t yet installed the WD Sync app on my wife’s laptop, (She a bit fussy about what I do to her machine.)
But what I have done is this.
I took my laptop to my neighbors home and connect to his Ethernet network.
Then after clicking on the WD Sync app in my task bar, I chose the “settings” option.
It could not find my local My Cloud device (of course) but when I logged in with my My Cloud.com user id and password, it was able to find my WD device and proceed to set up and actually sync my folders.

I am not able to do that at my home when I have both a local area network connect as well as a MyCloud.com connection.
Or, if I only have a local area network connection to the My Cloud device.

It “sounds” to me as if the WD Sync app, has an issue using anything other than a My Cloud.com user id and password.

It works great, but what I really want to do is have the WD Sync app find the My Cloud device on my local area network so that it will sync over the local area network rather than over the Internet using the My Cloud.com user id and password when my laptop in at my house. (Which is 99.9% of the time.

Weird.

1 Like

Okay then, the issue has been resolved.
Based on "jpeng’s"suggestion, I installed WD SYNC on another computer in my home.
And when I WD Sync worked perfectly.
In that,the install\setup was able to find the local My Cloud device.
So, I wondered (to myself) if the issue could be “service” related.
And sure enough, when I compared the running services on the two pcs, there was one that was disabled on my pc but running on the other.
Don’t know why.
The service was named SSDP.
I changed SSDP from Disabled to Manual and then started it.
As soon as I did that, WD Sync was then able to find my local My Cloud device and then allowed me to log in and run the sync operation as the local admin.
And boy it really “COOKS” when run locally as opposed to running it with a MyCloud.com user id.

Thanks to jpeng for pointing me in the right direction.

Ray in Wisconsin