WD SSD not detected in cloning program

I am having no luck in using the Western Digital edition of Acronis TrueImage software to clone my laptop hard drive to my WD Blue SATA solid state drive. When I launch the program, a “Product Activation Required” page appears with a button (Rescan) at the bottom. When I click that button, supposedly to search for a qualifying (WD) drive, I get the following message:
“No new hardware by Western Digital has been detected. Please make sure that your new hardware by Western Digital has been attached to this system or can be detected in your local network, then try to renew the license again.”
I keep getting this same result even after uninstalling and reinstalling the program.
To check whether my Western Digital SSD is defective, I attached it to another laptop and tried doing the same procedure (cloning). Detection of the SSD was successful on that other laptop, so I conclude that my SSD is working just fine
My system is Windows 10, 64-bit, latest update (21H1).
Help from forum members as to what could be causing this detection failure would be greatly appreciated.

Hi,

Please refer to this KB article: How to Manually Clone a disk with Acronis True Image WD Edition software

Thanks, but I already did my cloning using the free Macrium Reflect software download, and it went so smoothly, no hitch at all.

Courtney Leigh