WD SmartWare won't install

Yesterday, I formatted My Passport Essential 500GB and reinstall my OS… Now I want to install WD SmartWare that I downloaded from WD Support but it always say The Program Doesn’t Start From Drive or something like that…

I know it means I must run the software from the drive that given… But I already formatted my drive and it’s all gone… How can I install WD SmartWare now?


Visit the link below, you will find information on how to restore WD Smartware to your drive:


Remember, you Must copy all files and folders to your external hard drive, in order to reinstall Smartware.


I must download all the file

WD SES Driver (32-bit)

WD SES Driver (64-bit)

WD SmartWare Disk Image for Windows

WD SmartWare Disk Image for Mac OSX

or just

WD SmartWare Disk Image for Windows

Thx btw… Now downloading…

Just WD SmartWare Disk Image for Windows.

Hello, i recently bought the WD my passport 500gb installed it and it worked fine. however, yesterday I went to get onto it but i couldnt. I set a password for the passport when installing it so each time i plug it in to use it i type that in and it unlocks it as usual, then i go to open it but it freezes and wont let me on it, i tried the so many times a ithough uninstalling it then reinstalling it would work… but it didnt. when i go to install it it keeps on asking for a disk to read some information off of but the pack didnt come with a disk and i didnt get this problem the first time i installed it.I then looked into it on this website and I followed the instructions you gave to this person but I cant get  the passport to open to extract the information onto there… wat do i do?? hope this kinda makes sense … thank you

The link to download the version for Mac won’t open any dowload page. I don’t know if it is just for me or not, but all the other links seem to work except for the Mac one. Any direct link to the download?

Thank you.


I did just that but I still receive the message “Application not started from drive”. What do I do?