WD Smartware will not allow me to retrieve all files

Hi All,

I have a 500MB My Passport HD.  I am using WD Smartware ver.  Win 7 64bit.

I create a selected file back up within the software and it backs up properly.  When I try to retrieve a file (using “Retrieve some Files” option)  from the backup, the folders that files reside in do not expand and the files are not accesible.  In addition, if I select the “Retrieve all Files” option, it only shows that it will retrive a selection of files that is smaller in size than my entire backup.  “Data Backed Up” on the Backup page shows as 11.85GB, but “Data to Retrieve” on the Retrieve page only shows as 7.47GB with “Retrieve all Files” selected.

I uninstalled the software the other day and reinstalled it to see if I could get it to work.  That worked great… for less than a day.  After backing up my data, I went to the Retrieve page and was able to see every file and folder in my back up set.  A couple of hours later, it stopped showing all of the backed up files again and the folders containing the backed up files would no longer expand and the files were inaccessible!

Am I doing something wrong or is there a problem in the software?


You can explore the passport and look for the smartware.swstor folder. If you explore that folder you can manually copy your files.

1 Like

Thanks Alucard… that is an acceptable solution, but I wonder if there is a problem with the software then?

You can try to reinstall Smartware, to see if that solves the problem.

Unfortunately, I already tried that (see original post).  It worked for a day and went right back to doing the same thing it’s doing now.  *shrug*

Oh well… Iwill just browse to the files inthe backup through te explorer as needed.

Thanks again!

Sorry I cant help u but am commenting as I have had a similar problem. I backed up alot of files then when I tried to retrive them, all the hhtml files and .swf and .flaa files were missing. It only retrieved some jpegs and ai files but wouldnt bring back all those other formats. So all my web design pages are missing !!! So not happy with this software. Also kept crashing and ggoing very slow. Doesnt seem to work properly at all.