WD Smartware VCD and Firmware Updater Mac problems


#1

Hi WD Community

I’ve just bought myself a 1TB My Book Studio and I’m having some issue with Smartware. I’ve been trying to prevent the Smartware CD from mounting everytime I boot my computer. I followed the instructions on the WD support website. I downloaded WD Virtual CD manager 1003 from the WD website and it told me that the firmware in my drive was out of date (the drive’s firmware version is 1.004). So i proceeded to update the firmware of the drive. When running the updater, i get the error “No Western Digital Essential or Elite Device Found. No WD Essential or Elite devices were detected on the USB bus.” I’ve also tried to update the firmware and disable the VCD in Windows 7 as well and I get similar errors. I have tried connecting the drive via USB and Firewire (800 and 400) and nothing’s helping.

Any help would be much appreciated! I’m starting to get irritated my the VCD from mounting every time I start my Mac. I’m assuming that WD hasn’t updated the website for these new drives and that the posted firmware are for different drives altogteher? 

Many thanks.


#2

I’m having the same issue. I’d like an answer as well or I’m sending my device back for a full refund.


#3

I have the exact same problem - have spent hours looking for a solution.  Still haven’t found solution, other than never buy a Western Digital drive.

Please get rid of this vcd WD SmartWare, hate it!


#4

I believe there is fix for My Book Essential and Elite, but not Studio model.

I think they are working on My Studio Firmware & Updater process to remove VCD feature.


#5

Hi all.

I managed to get rid of any trace of the vcd, but unfortunately before I could copy the smartware software or install it. The only reason I need the software is to change the e-label. Can anyone send me the contenets of the vcd?

by the way, I got it off by entering this one line in terminal and then formatting using diskutil:

sudo sh -c "echo UUID=`diskutil info /Volumes/WD\ SmartWare/ | grep 'UUID' | awk '{print $NF}'` none hfs rw,noauto 0 0 >> /etc/fstab" 

#6

Try below.

http://www.wdc.com/wdproducts/updates/?family=wdsmartware for Windows.

If Mac, click Mac users on top.


#7

 tried that; doesnt work. I have a my book studio for mac; that update is for elite and essential models.

I dont really need/want the firmware, just need the wd smartware software on a temporary basis to change the e-label.

Possible you can copy wd smartware from the vcd and send to me?


#8

joshuap,

tried that; doesnt work. I have a my book studio for mac; that update is for elite and essential models.

You are correct.  It seems to be working for My Book for Mac and My Passport for Mac and not for Studio model.

Possible you can copy wd smartware from the vcd and send to me?

It’s like 30MB in size, so too big to be send over via e-mail.

Do you have ftp or some way to upload larger file?


#9

Hi

Thanks again for the reply. I use dropsend.com for this type of thing. You can send up to 100 mb for free. sign up for a free account (no spam here), upload the zipped file and send.

you’ll need my email address to send…


#10

Actually, you can download the latest software version of WD SmartWare from the same landing page above.  Here is the link to the Software download.

Windows

http://download.wdc.com/smartware/WDSmartWare_SoftwareUpdater_for_Windows_1_2_0_7a.zip

 Mac

http://download.wdc.com/smartware/WD_SmartWare_Software_Updater_for_Mac_v_1_0_4.zip


#11

thanks, but these are updaters for software (wd smartware) that I do not have installed on my machine.

Im looking for the original software that came on the drive bundled on the vcd, so that I can install, then use the updaters.


#12

joshuap,

I am sorry to confuse you & Bill_S.  I only have 1.2.0.7 which you mentioned doesn’t have My Book Studio support.

I think your Studio had higher version of WD SmartWare which supports My Book Studio model.

I think best way I can think of is to use 1. VCD Manager again to “enable” VCD, 2. install WD SmartWare, 3. change Label, 4. run VCD Manager to “disable” VCD, and finally 5. uninstall WD SmartWare.


#13

okay.

I understand what you’re saying and I appreciate it. However, I don’t have the vcd, the smartware, anything. The vcd disappeared when I formatted my drive, before I had the opportunity to install it… That’s why I need the wd smartware. I have no means to enable or disable the vcd; it isnt there.The vcd manager wont install either.

I guess if anyone has the My book studio model for mac and is willing to send me the zipped contents of the vcd, I’d be very grateful.

I don’t want to return the drive; it works well. I just need the smartware to change the e-label. That’s it.

Thanks!


#14

By the looks of the code that you provided ("sudo sh -c “echo UUID=diskutil info /Volumes/WD\ SmartWare/ | grep 'UUID' | awk '{print $NF}' none hfs rw,noauto 0 0 >> /etc/fstab”). You had the Mac force a dismount on the VCD. Unfortunately this is something that we cannot support and do not know how it will interact with the VCD that is built into the drive. This type of dismount is typically only performed on the Mac that you ran the command on and it should mount fine on another system. You will most likely need to type a command to re-mount the drive using the terminal, then use the SmartWare software to properly disable the VCD.

If the terminal command that you ran allowed you to re-format the drive, thereby removing the VCD totally. You will most likley need to replace the unit since there is no way to put the VCD back on to the drive once it has been removed in an ‘unusual’ way.


#15

Let’s try 1 more time.

Click here http://www.wdc.com/wdproducts/updates/?family=wdsmartwareutilitiesmac 

Click “Download Now” under VCD Manager for Mac

WD already has VCD Manager for Mac without downloading entire WD SmartWare

good luck.


#16

that worked until I got to the screen where you select the drive. My drive appeared in the drop-down menu, but the “configure” button was grayed out. It said that it wouldn’t work with the firmware I have installed and that I should update it. Problem is, the firmware updater posted on their site won’t work with My Book Studio.

Looks like I totally wiped out the VCD, which is fine, but I still need the smartware to deal with the elabel.

Listen, I appreciate all your help. I guess that either:

  1. I need the smartware that came bundled on the drive’s VCD, which apparently, I wiped out during a reformat. Updating the firmware might help retrieve the VCD, but the firmware update for this drive isn’t yet available.

  2. Someone could (preferably with the same drive) could send me the bundled smartware, and I don’t have to worry about this firmware update.

Im not taking this drive back. I drove 30 miles to a Fry’s to get a good price, and frankly, I dont really want the VCD for anything other than the smartware so I can adjust the elabel. Im glad I was able to wipe it out, but rue not copying the smartware files first, before I did it.


#17

1.  What Firmware do you have on your drive?  Look inside the System Profiler and pick USB > WD.  USB is easier to find than Firewire.

2.  How did you Disable VCD in the first place?  You must have used other than VCD Manager to disable the VCD as you can also enable VCD using VCD Manager if you have the correct FW.  If you have the right FW, the the setting to enble VCD should not be grayed out.


#18

Firmware:

  Firmware Revision:    0x1004
  Product Revision Level:    1004

I effectively forced a permanent dismount using a sudo command in terminal. The reformatted. The VCD Manager won’t install because it says I need to update the firmware to use.


#19

joshuap,

My friend had same drive with same FW and reproduced your issue where “Configure Drive” is grayed out.

I think 1004FW doesn’t have VCD Disable/Enable feature.

I think you just have to wait for new FW for Studio to be released.


#20

I have several WD Disks connected to Macs. I like them. But I have recently installed a new WD I think called My Book for Mac for a friend. The user manual advised that during the installation I would be asked to state if I wanted to use Time Machine rather than the WD SmartWare. This option did not appear. I managed to make the disk use Time Machine and this seemed OK for a while.

The problem now is that the disk often disconnects and when it is switched off then on it connects as a WD Smartware Virtual CD. I’ve tried to get rid of the Smartware itself with no success. Its driving me nuts and I have a new disk that I can’t use.

Help please!