WD Smartware updater broke my installation


Just unboxed the MBL and ran the CD that came with it, all ran and setup fine.  Noticed I needed the firmware and software updated.

I downloaded the latest firmware and updated my MBL just fine. I also downloaded the WD Smartware updater 1.51.6 and it ran successfully, until I tried to run the software.  I got an error that it could not run.  So I tried to uninstall it from control panel and install from the updated ISO image from the site.  When the install process runs, It tells me it’s going to ‘start upgrade’ though I uninstalled it.  I then get an error 1605 installation unsuccessful.

I checked, and teh WD Smartware Drive Manager is still installed and I cannot remove it with Control Panel, it tells me there is a problem with the installer package.

Please help.  how can I install the WD software from scratch.  The WDL is up and running fine BTW

Windows 7 X64



This is a known issue, just repair the registry to erase the repeated Smartware entries and install the update directly without the original version.

1 Like

Kudos!  Took a while to clean all the entries out of the registry, but the update ran and works,

Thanks again,


Any time :smiley: