WD Smartware Update Exception Error

I am being prompted on my desktop to install an updated version of the software - when I try to do the install I get the same error each time - “the type initializer ‘system.windows.automation.peer’ threw an exception”, and the install window closes.

Anyone experience this or does anyone know what to do to fix this?

Tried downloading the software from WD but the installation doesn’t run (closes after the initial window when you press “next”…



I would recommend performing a system and registry clean-up, and ensuring Microsoft .Net Framework 4.0 is installed. If WD SmartWare still refuses to update afterwards then I would proceed to contact WD’s Support Teams.


Thanks for getting back on this Trancer - I had gone to Microsoft’s site and downloaded Net Framework but on install it said I had a later version so wouldn’t install.

As far as a system or registry cleanup - what software do you use to undertake this ?

Thanks again.


I also had same problem.

I have My cloud 3TB HDD and My Passport 2 TB HDD.

I connected the external 2TB HDD into my laptop to use it for faster backup directly from the laptop, using the Smartware software but i kept getting the same error ( ‘system.windows.automation.peer’ threw an exception’)

I reinstalled the application and did registry clean, but with same problem.

Any help please.


I found the cause of this problem.

It is due to a missing dll file called UIAutomationCore.dll , the x64 version.

please see the below link to download this file and replace the one in your Windows/System32 folder if you already have one in your hdd.


After I replaced my file, the application ran successfully without any problem.