WD Smartware problems

So I just bought a 1,5 Tb My Book Essential Hard Drive and I am getting that problem in which the Smartware gets an unexpected error and exits… I have read what to do in the WD site and updated everything… Yet the problem still remains… Any help?

Although I am a bit unsure about where you are at with the install and what you have tried thus far, you might want to go back to square one. Prior to any software updates or hardware install I always create a restore point of my system in a good working state to avoid going down a path and not knowing how to get back.

  1. Uninstall any versions of Smartware from your system and reboot after disonnecting the device.

  2. Manually go to http://update.microsoft.com and double-check that you have all high-priority AND optional updates installed; more specifically the .NET framework.

  3. First uninstall from your add/remove programs adobe flash player. Check for latest versions of adobe flash player here: http://adobe.com

  4. Reconnect the device and Update the Firmware(if applicable) and then software here:


  1. Try running the Smartware backup.
1 Like

It worked!! Thanks a lot!!


i am having the same problem as was first stated - namely, that when i try to install the wd smartware, it either hangs or quits with an error report. The only difference is that I have a mac running mac 10.4. Do you know how to fix this error on a mac? Also, I have the my book essential (2tb) and I have already reformatted it to be compatible with a mac using disk utitlity. The only other problem I can think of is maybe I don’t have enough space on my (internal) hard drive to support the installation? I’m not sure, but either way, any help you have would be greatly appreciated.

I’ll admit up front I don’t own a MAC and I am mediocre when it comes to troubleshooting that OS. When you formatted the disk in disk utility did you use the options button and pick Apple Partition Map and uncheck the drivers for OS9 (I think that’s what it should say) and then reboot your system afterwards?


You can also try running First Aid from the disk utility and check for any fixable errors through permissions and such along with using the bootable OS CD for extensive repairs, but that is a procedure you will have to refer to Apple support  for with the finer details of performing these functions.

Sometimes you may find that when you are using an older OS, newer items such as hardware and more commonly software might not work in that particular system. I would still update the firmware if applicable after completely removing any versions of the Smartware application from your system. Double-check with Apple support for any new updates as you will find that most software manufacturers release new products with the latest OS versions in mind. I apologize if none of this helped you further. Still, reaching out to the MAC community would be a great outlet for information and further troubleshooting.

thanks very much. i rebooted and everything went off without a hitch. i really appreciate ur help!

I did ewerything like u said same problem the smartware wont start

I have a HP Pavillion with XP Home SP3, I just got a 1TB WD My Book Essential.  I got the error as mentioned  above, did everything you said, with exception of updating software because the software updater kept crashing as well.  What do you recommend that I do?

Two weeks and no input on my dilemma.  I see you guys will be of little help so I will just remove the SmartWare and use the drive without it.

Hello, I just got a “500GB my book essentials” at first it was working great, but now I can’t get to my files on the drive and the icon will not show on My computer. When I unlock the drive with my password, it still does not work. Can someone please help me

When I plug in the passport it doesn’t appear to be backing up the system as it did the first time I used it. The backup button is grey. Any suggestions?