WD Smartware not Smart

My Book Live (MBL) have been used to make Data Backups of my laptop.

Last week I had to reformat my laptop’s hard drive.

I re-install the Windows 7 64 bit Home Premium and the other required software/programs.

My hope was that I could retrieve/restore my Data (Files & folders) Backup from my WD My Book Live network storage to my laptop.

I used the original Software CD (dated Sept 2011) to install the WD again.  The Software CD installed some programs that discovered the WD drive on the netwrok. It also installed WD SmartWare release 1.5.1.6 on my laptop.  The firmware that is on the WD MBL drive is 02.43.03-022.

All good, hu?

NO.

This WD SmartWare release 1.5.1.6 on my laptop displays a message about my WD MBL:
No Writable WD Smartware partition found.

But my Backup exists on my WD MBL, I can see the date files via Win7 Explorer on my laptop.

Also, this WD SmartWare release 1.5.1.6 is wanting to update to release 2.3.0. (Reading this forum it seems like 2.3 does not even work, **bleep**).

 

My questions:

1) Why is WD SmartWare release 1.5.1.6 showing this message: “No Writable WD Smartware partition found”?

When I first bought and installed this, there was no message like this.  It all just worked.

 

2) Should I upgrade to WD SmartWare release 2.3.0?  Rememeber, I have no idea what the Release of WD Smartware I was on when the last backup was made (before I re-installed Win7).  Also, will an update to WD SmartWare release 2.3.0 format by WD MBL and wipe my existing Backup?

 

3) How can I figure out what release for WD Smartware did MBL use when it did the last backup (before I reformatted my laptop)?  And where can I find this version on the WD site? 

I have to say this as well; WD take it anyway you like it.

The WD documenetation stinks.  There is no instructions on how to retrive backups. Ironically, backup retrieval is the reason for the MBL existence, FFS.

Page 47 of

http://www.wdc.com/wdproducts/library/UM/ENG/4779-705057.pdf

ASSUMES you have the correct release of the WD Software installed, and assumes that the Retreive TAB is available (in other words, no partition errors).

Users first have to install/reinstall the WD Software to retreive backups.    The documentation just assumes you have WD Software already.  FFS, it may as well just say retrive your backup and be doen with it. 

No reference to: Install the WD Smartware from where, what release? How do you ensure it was the same release as the last backup?  What should you do if you have this partition error.  WIll this updated software release wipe my existing backup - condering WD notes like Note: If you are running WD SmartWare version 1.1.x or 1.2.x, you are required to set up and enable a new backup plan once the WD SmartWare 2.0 upgrade installation has completed. ?  <- That note does not even make sense.  How do you do this, what is teh concequesces if you do not do this?

My resort is not to manually copy my backup to an external drive.  It will take some 23 hours to do.  I have to do this because I can not trust this WD Smartware.  It just does not work.

Can a WD Smartware software developer please clarrify this?  I knwo it is only users eher, but surely WD developers reads this forum or are they completely disconnected from their customers - that would explain a lot actually.

Also, how do we ask the WD people to  update their documentation so that users can actually use your manuals?

In fact, the whole reason people buy this WD MBL is to retreive backups when needed.  For WD not to make any effort in explaining how to retrive it, or addressing the abvious issues with their software is a disgrace.  This is like BMW not having any instructions how to start their car, hiding teh ignition.

It’s incredible how WD can actaully miss the central tenent of their own MBL’s existence - to retrive backups, not to stifle customers.

The WD Smartware software will not allow a backup if the drive is not visible by the interface.

This could happen if the drive is not mapped on the network and/or the firewall/Internet security is blocking connectivity.

Is always good to run the latest version to ensure better performance.

Once the drive is recognized by Smartware the backup and retrieve tabs will be accessible.

Thanks.

Am not quite sure you read my post at all.

In fact, you have not responsed to any of the questions.

You just posted what my problem statement is, as if I do not know it.

The WD MBL Drive is mounted - I can see/view all the content of my back up via Win7 Explorer on my Laptop.

The issue is that the WD Smartware on my Laptop can not see it.  It’s interface says ‘No Writable WD SmartWare partition found’ .

Can you answer my questions?

Hi WD-LIVE, once your My Book Lives shows up when you hover your mouse over the WD Quick View icon, you’ll be all set.  I’d specifically make sure your firewall isn’t blocking uPnP, Windows File Sharing, or network discovery services.

Steps 1, 2, and 3 from the knowledge base article below should help you troubleshoot your computer once it fails to detect the drive.

How to install a My Book Live or My Book Live Duo on Windows (8, 7, Vista, or XP) or Mac OSX for the first time

If all else fails, please feel free to contact WD Support. While this is a problem with the system in particular, Support might be able to find the incorrect setting.

Thanks, but you have not addressed my issues at all.  In fact, all you did however kick them around to avoid adressing them.  Well done!

The current version of Smartware is 2.4.1, at least according to the install I have at home on my netbook. I agree the software isn’t so smart or effective, but for a free bit of software it’s not too bad.

One initial question - have you updated your MBL firmware since the original set-up (when the old version of the software that you have worked)? A mismatch there could possibly be why things aren’t being seen perhaps.

Also on your MBL, what is the name of the folder that contains your back-up? From my MyCloudMirror it should be a folder “Smartware” in the root, with sub-folder “WD SmartWare.swstor” below that with then further sub-folders for each machine that Smartware has backed up, sub-divided again by the hard drive volume ID. If any of those folder names have been altered then that could perhaps explain why it’s not being found by the software but is visible directly via explorer?

To answer Q2 - no, it won’t wipe anything to update to 2.30 (or 2.41). The Smartware is the software that runs on your local PC for communicating to the MBL (or MyCloud in my case), rather than anything that runs on the remote WD drive itself. But what it means is that your old list of files/folders to be backed up won’t survive the upgrade you mentioned, so will need to be set-up again. In your case as you’re trying to recover rather than start backing up again, I’d say 2.4.1 is your best shot.

The download link for MBL software from the WD site is:  MBL Software Link - sorry I’ve no idea about if/where older versions of Smartware may be available from.

The link in the above post should also be valid, as it’s aimed to set the drive up for the first time (as it will be as you’ve done the Win7 reinstall) and so it should set everything up fresh with the latest up to date version of the software for the drive. Your disc is of course 3 years old now, so will contain older versions of the software (as your Smartware clearly is from the version number you posted). If you (or it) have updated since that original installation in 2011 and also your firmware has updated on the drive for example, then that could perhaps explain things.

If I were in your situation I’d try the latest software versions (either from my link in this post or the one given in the link posted above by Ichigo) and see if that helps or not.