WD Smartware Not Recognising My Passport (older version)

Hello,

I had to have a new hard drive put into my computer at the end of last week and so had to download and reinstall the software for My Passport. This has been done. I can open the software, but as soon as I plug in My Passport, a windows message appears WD Smartware has stopped working.
cannot remember when it was purchased but it is quite a few years ago.

FYI My Passport was working fine before my hard drive crash, it is just since I had to reinstall the software to my computer that I am experiencing issues.

Any information and help would be much appreciated.

An update: Have used the WD Drive Utilties and the portable hard drive has passed all those tests fine. Now when I try to open the WD Smartware icon I am getting the WD Smartware has stopped working error message and have to close the program. This is not much good as I cannot access my backed up files.

Feather48

Hi Feather48,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.

Thanks for the response Brandon P and I did just that. I have uninstalled and reinstalled and everything seems fine at the moment. Did have WD Security and WD Utilities installed as well when reset up my computer, but haven’t reinstalled these again and wonder if these could have caused the conflict as without them the WD installer is working perfectly. Haven’t reinstalled firmware updater either in case this was part of issue too. I’m not sure whether there will be anymore firmware updates for my passport as extremely old and only on version 1.25 now. What do the community think of not reinstalling the firmware installer?

Feather48