WD Smartware just hangs (freezes) on the installation

On my WD 2TB USB 3.0 Ultra, there was an update yesterday, so I took it. (big mistake).

It wouldn’t install.  Now, no matter what, the installation hangs at “scanning for hardware changes”.

I’ve tried 3 different installations.

WD_SmartWare_ Installer_2.4.1.9, WD_SmartWare_Installer_2.4.0.39, WD_SmartWare_Installer_2.4.2.26

as well as the various installion software on the drive itself: WD SmartWare Setup (x64).msi, WD Apps Setup.exe.

I’ve installed the WD SES Driver Setup, but didn’t help. I’ve disabled legacy USB support via the BIOS,but didn’t help.

It just always hangs at the “scanning for hardware changes…”

Any ideas??

I’m using: Windows 8.1 Pro.

*The original installation was on a ASUS mobo, and around a month ago, I swapped it out for an ASRock mobo.

All was fine, until I tried to install an update yesterday.



Not sure why you are getting that message since WD Smartware is a software and wont make any changes on the hardware of your computer.

Are you able to use the drive on a different computer?

Have you tried to run the installation without the drive connected?

Solved (finally).

First, yes, it installed it on another pc (my laptop), easily.

Here was the silly problem.

The install would hang on the “searching for hardware changes”.

With that, I went into device manage, trouble shooting, hardware & sound, hardware & devices, next…

just so that it’d search for “hardware changes”.

SAME thing. It just hangs there.

So the problem isn’t the install. The install was just a victim of something that’s wrong on the desktop (bad driver, setting, or something) that causes the “searching for hardware changes” to never complete.

Here’s how I fixed it.  I restored the pc back to a previous restore point that was before I attempted the install. That did it!

Thanks for your help!!