WD Smartware has stopped working

I have a My Book Essential External Hard  Drive

When I trun on my computer I get an error message

WD  Smartware has stopped working ?

Any suggestions on what to do ?

Please and thank you

Thread moved to WD Software & Accessories: WD Smartware.

I suggest you to try reinstalling Smartware, as it seems to be a logical issue.

WD Smartware works fine when you have Microsoft .Net Framework 3.5 and Adobe Flash Player, do you have those softwares on your computer?

I am getting the same problem.  I have W7 Premium 64bit.  I have .net 3.5.1 turned on in “Turn Windows features on or off” and I have the latest flash player - still no joy.  I did install exerything on my collegues XP laptop so I think this is a W7 thing.


Try this:

1- Uninstall WD Smartware and restart the computer.

2- Make sure you have Adobe Flash Player (Latest version) and Microsoft .Net Framework ( version 3.5 or 3.5 SP1 recommended)

3- Download WD Smartware from HERE and Install it again.

Let me know if this solve the issue.- :smileyvery-happy:

I have tried all that during several support calls.  Nothing works.  My collegue with the same laptop but runnnig XP (I have W7 64bit) is using it fine.  I’m going to order a non WD drive and seperate software for my backup solution.  It is a shame, I liked the whole WD package.

1 Like

If WD Smartware is not installing or working properly, since you have Windows 7 you can use Windows Backup to run your automatic backups on your drive.-