WD Smartware has stopped working - My Passport

All of the software associated with My Passport is not working - WD Smartware, Quick View or Drive Utilities. I am still getting notifications when and update for WD Smartware is available but when I try to install it I get the message “WD SmartWare installer has stopped working - A problem has caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.” The program closes but there is never a notification with a solution. This started happening in June and I have been away so am just getting back to it.

I am anxious to access my backup files on this drive as I am looking for some lost material that might be there.

How should I proceed to get this software reinstalled and working properly?

Hello,

I recommend you uninstall the software and proceed to download and reinstall from the WD website.

Thanks for your response.
I tried your suggestion with the following results:

  1. Successfully deleted Drive Utilities, Quick View and WD Smartware

  2. Tried to install WD Drive Utilities 1.4.0.92. The zip file extracted with no problem and when I acitvated the .exe file I got the “run” box but when I clicked on run, the “blue wheel” spun for a couple of seconds and stopped - nothing further happened.

  3. Tried to install WDSmartware 2.4.16.16. I clicked on the WDSmartwareInstaller.zip file and then on the WDSmartwareInstaller.exe file and got the “run” box. Instead of installing I got the messge that “WD SmartWare Installer has stopped working. A problme causerd the program to stop wroking correctly. Windows will close the program and notify you if a colution is available.”

  4. Next I went into My Passport and found the original applications file. Both the Drive Utilites (Ver. 1.0.3.3) and SmartWare (Ve. 1.6.4.7) installed with no problem.

  5. With the old versions installed I tried to install the updated version mentioned above with the same unsuccessful results.

  6. Tried to open the old version that I had installed. Drive Utilities would not open - “blue wheel” spun a couple of seconds and stopped. Smartware did open but the Backup and Retrieve Tabs are inactive. The only active taps are Home, Settings, and Help. I message popped up saying that an update is available but when I clicked on it I was directed to a page that was no longer available.

Do you have any suggestions as to where I can go from here. I seem to be at an impasse!

Thank you for your response Craig.

I logged on to the support site but it requests an RMA # which I don’t have. Followed a link that said “To return a product (RMA) please log into our Support Portal”. I did this and was requested to register my product which I tried to do but got the message “Thank you for registering your product(s), 0 product(s) were registered out of 1. The following asset(s) failed to register: because it’s either an OEM product or the warranty has been voided. For further assistance, please contact the WD support team.”

The S/N is - WDBY8L0020BBK and it was purchased Dec. 10, 2013 at Costco and is defintely a WD My Passport, not an OEM.

Where do I go from here? Is there any way to contact support without the RMA # which it appears I won’t be able to get because my drive is 3 years old (which I personally feel is a little too young to be extinct!). Will appreciate any help or direction anyone can give me.

Sorry I’m late. Thought I previously copied the Link below which does NOT involve an RMA#.
I just Clk’d on it in the preview screen and it gave me a “normal” Sppt Question Form.
Will try to watch if this doesn’t work - & - if you haven’t found a solution already.

Thanks Craig. I have just submitted my problem on this form.

Great… On my last request for help I got a confirmation (ie) “Sppt Request Recvd” early on a Monday and recvd a Reply about mid-day of Tuesday.

If a resolution results that’s easy to describe it may help others to post what they had you do to fix things.

Good luck! Craig

Thanks very much Craig. They contacted me and although problems on my hard drive are still giving me problems with Wdsmartware they loaded another program that will do my back up for me so all is well.

Thanks for the update. Good luck! Craig