WD SmartWare cant see Backup target

Hi,

First of all sorry for my bad English. My name is Petar and I have problem with configuration of WD SmartWare software. I use WD My Cloud 4TB bought in May/June 2015. The problem is that when I connect WD My cloud to a Windows Server 2012 it can’t see as backup target WD My cloud, instead, it only showes Dropbox (with login requires). WD My cloud is seen on network and I can manage folders, Dashboard works proprely, WD Sync is working well and other related software. So only problem is related to WD SmartWare. Additional, first when configured it on Windows 8 WD SmartWare it worked properly, seeing WD My cloud as backup target. Thanks.
Beside that I didnt found out on Learning center what is difference between WD Sync and WD SmartWare?! So can you answer me on this question too?

Best regards,
Petar Šukara

1 Like

Peter, I have run into this problem as well.
First I wanted to find out if other applications/programs could find/discover by EX2. I used web browser (IE, or Firefox) and entered the IP address of the EX2 something like 192.168.1.3 . IF the browser could not find it then I knew it was likely not on the network. But since you stated Dashboard works properly, which means dashboard does access the external drive and it is just a smartware problem. If Dashboard does not recognize the the drive then per WD instructions power down the external drive for at least 30 secs and restart it.
Second I used “My Net View” "WD Discovery to ensure WD applications could find its own drive. :smile:
My problem was that I discovered that the drive had not connected to the network so the reboot/cycle power worked.
While you can get to the setting through the “Dashboard” do this through Smartware by going to Settings > set up drive> this should open the dashboard as well. In here go to settings and examine network and the utilities. If everything works here, then I don’t know what is wrong.

In this case, I (maybe not others) would have to start all over - uninstall Smartware, as this appears to be where the problem is, if everything else works i.e. recognizes the drive and you can read and write to it (file manager can do this). And reinstall it if you think smartware is smart. This would mean that possible new backup plans need to be made and you have to delete the current backups to get space back. (This is in the manual)
Good luck

Hi TTWB,

I did everything you said before writing my first post. I used WD Discovery and it findes WD My Cloud drive with its IP adress, serial number and all other information. I did examine network and everything worked well. I have restarted external drive and nothing happens. I did reinstall WD Smartware and it didn’t solve the problem. I downgrade instalation of WD smartware software to 1.xx version too, but the problem wasnt gone.

What do you think of my opinion what could problem be?

  1. Problem could be in instalation files, because on disc C:/ I have “Program files” and “Program files (x86)”, and there I can see two folders of Western Digital, one in Pf and one ine Pf(x86) so maybe WD smartware should be installed in Pf(x86) so it could recognize network and later in program backup target.
  2. Exterlan drive (WD My Cloud) is connected via MicroTik and not via Router so maybe there can be a trigger. But since all other related software can see WD my cloud I think this is not the problem.
  3. Windows Firewall or maybe something other blocks specific ports that WD smartware uses so it cant see backup target.

What do you think about copying instalation and all other files (log files) form computer where it works to computer where is now (and where it doesnt work)?

And please can someone answer me the question I asked: “Beside that I didnt found out on Learning center what is difference between WD Sync and WD SmartWare?! So can you answer me on this question too?”

Thans everyone for reading this and trying to help.

I replied to my post but anwser is to you, so I type this so you can get notification and follow this post. :smile:

Anyone please? :smile:

I have the exact same problem.
I tried with different .Net versions (saw this in another forum), I have also disabled firewall, antivirus, … and much more. I believe that WD needs to come with a new software because lots of people have issues…

Thanks WD for making my life better…until now.
I reinstalled windows and it seems that you are just incapable of making good products anymore…

1 Like

Thanks WD for selling me a trash product. I have my all backup files but I have to locate them manually since your software is useless. By the way your support page is a trash too. Thanks a lot.