Wd smartware application problem


#1

Hello,

I just bought WD My Passport Essential 320 GB. I installed WD Smartware. When I tried to use it error appeared : “to run this application, you first must install  one of the following versions of the NET.framework: v2.0.50727”

I checked the instaled version of NET. framework and I realized that I have install the latest version including v2.0.50727. So I do not know why this error appeared.

Then I tried to re-instal the WD Smartware. When I tried to unistall it this error appeare: “there is a problem with this Windows Installer package. A program run as part of setup did not finish as expected.”   

Now I am really despairing. I can not use it , I can not reinstal it. Please help what to do.

Dder


#2

Have you tried contacting WD’s Technical Support? I would consider giving them a call about this. 

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en