WD Smart Ware not able to see mycloudmirror

Hi,
I can map a network drive (Z:) on my PC and access mycloudmirror without any problems. I can access the dashboard without any problems when on my local network as well.
I can access and sign-in to Mycloudmirror from an external network (https://files.mycloud.com/), no issues so far.

I’m using Freefilesync to backup my PC to mycloudmirror.

  • OS Windows 7
  • Firmware Version 2.21.111

ISSUES:

  1. WD Smart Ware is not able to see mycloudmirror. I have only the Dropbox option available.
    I do not want to make any backup to Dropbox. I just want to backup my PC to Mycloudmirror using WD Smart Ware.

  2. Not able to “see” mycloudmirror through My Cloud Mirror setup program.
    Error message: “Make sure you have properly connected the provided Ethernet and power cable and the LED is a steady blue, then click Rescan.”

  3. WD Quick View is not able to see mycloudmirror.

Kind regards,
André.

Hello,

What version of the software are you using?

Make sure that you are using the latest version from the WD Support site

I just bought MY Cloud Mirror and have the same issue, WD Smart Ware not able to see mycloudmirror. Any workaround for this?

It does not make sense for me to buy WD MyCloud ut using WD SmartWare to backup to dropbox.

I’ve had this before and it was down to slow network speed (slow router combined with wi-fi as part of the link).

What network setup do you have (what router speed and how is your computer and MCM connected together via it?)

The other thing to confirm is you haven’t got a firewall or something like that blocking the connection between the two.

All is in my LAN. Router speed is 1000 bit/s and mycloudmirror is connected via LAN cable. My laptop is connected via WIFI/G.

No firewall in between mycloudmirror and laptop as all in LAN and same subnet.

I can map mycloudmirror to my Z: drive without issue.

From WD Quick View in my systray, I can rightclick and WDMyCloudMirror is available and there are only 2 options available:

  • Wake this Device
  • Forget this Device

Launch WD SmartWare, in Home Tab, Backup Target only have Dropbox and mycloudmirror is not available. Do I need to buy WD SmartWare Pro to get the option to backup to mycloudmirror? I am afraid, even after paying for WD SmartWare Pro, I still end up only having the option to backup to Dropbox.

Those are exactly the symptoms I had too.

When you say WIFI/G, what exactly do you mean? If it’s gigabit wifi then that shouldn’t be an issue, but if it’s 802.11g then that’s probably the root cause of your problem as that would be terribly slow (it tops out at 54Mbps, but you’d never get that in practice).

As a test, try directly connecting your laptop to the router via a cable and see if the MCM appears after a reboot of the laptop. If not then connect the MCM directly to the laptop via an ethernet cable and see then. If it still doesn’t appear then it’s a firewall or configuration on the laptop itself (Windows firewall or equivalent if you have a security package installed).

Being on LAN and same subnet makes no difference, you can have firewalls installed on the machine itself which will happily block stuff on the same network (been there, done that). Firewalls aren’t just between your local network and the Internet, although of course there should be one in that position on your router.

Thanks Darren for the tip. I use network cable and it can locate the MCM.

However, even when I’m using 802.11g, I am not sure why it does not work as I am still located in the same network and I can still map network drive.

I hope there is a way I can connect via 802.11g, even if its slower but its convenient.

But after a while, using network cable connection, it dissapear :frowning:

Still not able to back up.

I use direct cable connection, laptop directly connect to MCM.

Do you happen to know what port WD SmartWare uses to connect to MCM?

When I had the issue, the conclusion I came to is basically that due to the network speed (or lack of) the search/poll of available devices is timing out before the MCM can respond and be seen. It will also depend on the network traffic at the time, which is why devices can appear and disappear over time.

In the case of drive mapping etc you’re explicitly telling it where to go and what to look for, hence it doesn’t have to search but knows where to go and find it. You can sometimes have similar issues with the Windows Network itself (the network tab under Windows Explorer) if you don’t have a WINS server on your network. Drives and devices may not show up, but if you explicitly use their network names (\\WDMYCLOUDMIRROR for example) or their IP address (\\192.168.0.x or whatever) then they show up.

My suggestion would be to either use the wired option, or to upgrade your wifi link. Swapping wifi cards in laptops normally isn’t too hard, or failing that just buy a USB wifi dongle and use that instead.

Sorry no idea concerning ports - it’s normally handled automagically by UPNP. Indeed you may want to confirm that UPNP is enabled and available on your laptop.