WD Sharspace Thumbnail Issue

I have a problem with my WD Sharespace and WDTV Live setup

The Sharespace is connected to multiple WDTV Live boxes via my home network.

On the Sharespace I have loaded .mpeg movies and .jpeg cover art with corresponding names.

When I access the Sharespace from the WDTV as a Network Share the WDTV shows two Thumbnails one for the .mpeg file and the .jpeg.

When I access the Sharespace from the WDTV as a Media Server I get no Thumbnails just empty black boxes.

I have tried to get this resolved for a couple of years and am about to give up and buy QNAP products (NAS & Media Server).


You’re doing it wrong, you need to name the JPG the same as the folder itself, not as the movie.

Thanks for your input.

Yes you are correct if you want pictures for your folders you place a folder.jpg in the folder. However when you have 300+ movies you don’t want to create 300+ folders and then have to open the folder to access the movie.

There is no issue with how I have structured my movie and .jpeg cover art files, the issue is the implementation of the Twonky Media Server in the ShareSpace.

To prove this I have Twonky version 6 loaded on my PC with exactly the same file structure as my ShareSpace and it works perfectly.

Thanks again

Then what if you embed together the thumbnails with the movies?

I have not tried this. What software would you recommend to embed my .jpeg’s with the .mpeg files ?